Try to improve performance and connection MSFS 2020

1-CMD as administrator

netsh int ip reset c:\resetlog.txt (Press Enter)

netsh winsock reset (Press Enter)

ipconfig /flushdns (Press Enter)

exit (Press Enter)

2-Change DNS

Control Panel > Network and Internet > Network and Sharing Center
Let’s go to type of access connections (it will be highlighted in blue at the top right)
Click and go to properties> Select (Internet Protocol version 4 TCP\IPv4)
Click properties > General > Use the following DNS server addresses
Preferred DNS
Alternate DNS (OK and close)


CMD as administrator

regedit (Press Enter)

We look for the following route


Click on start and change the value from 2 to 4

4-Always run MSFS 2020 in high priority

CMD as administrator

regedit (Press Enter)

We look for the following route

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options

Right click on Image File Execution Options > New > Password and put > FlightSimulator.exe

Right click on FlightSimulator.exe > New > Key and put PerfOptions

Right click on PerfOptions > New > DWORD Value (32 bits) and put CpuPriorityClass

Double click on CpuPriorityClass and put in information of the value 3

5-Energy High Performance

(Recommend High Performance before starting MSFS 2020 and set to Balanced once MSFS 2020 is closed)

Control Panel > System and Security > Power Options (apply on Balanced and High Performance)

Change plan settings > Shutdown and sleep state (Never)

Change advanced power settings > Turn off hard disk after (We set to 0 Never)

USB Settings > USB Selective Suspend Settings > Settings (Disabled)

PCI Express > Link State Power Management > Configuration (disable)

6-We look for FlightSimulator.exe > Right click > Properties > Compatibility >
Disable full screen optimizations
Change High DPI Settings (Click on Override High DPI Settings Behavior (Application)
We do the same in (Change settings for all users)
Apply and accept

6-Windows Defender (or any other)

Manage settings > Add or remove exclusions > + Add exclusion > Process > FlightSimulator.exe

  • Add exclusion (All possible folders from MSFS 2020 and we know they are safe) Community,Official,Etc…Etc…

7-Device Manager > System Devices > High Precision Event Timer

Right click on High Precision Event Timer > Disable Device

CMD as administrator

bcdedit /deletevalue useplatformclock

bcdedit /set disabledynamictick yes

8-To be able to see the FPS with W+G (It has nothing to do with performance)

We look for Computer Management (Run as administrator)

Local Users and Groups > Groups > Performance Log Users (Right Click)

Properties> Add> We put username> Check names> OK> Apply and accept (Windows Pro)

*My settings are all ultra (I recommend V-Sync set to 30)
I hope it helps and if you have any questions, I’m here to help.
If someone knows more settings than sure if we can go adding and removing things.


One thing I’d suggest… if you’re going to use Google DNS ( /, make your secondary DNS something else non-Google (your ISP DNS or OpenDNS for example), because sometimes even Google’s DNS has issues. I had constant connection drops the other day that turned out to be due to slow response from Google DNS. Surprising how often poor internet performance is down to DNS having a bad day.


Cloudflare or OpenDNS :blush:

1 Like

Quad9 is what I use,

I don’t see how this is going to affect performance though. The other options, like disabling HPET, seem like a good shout, though.

1 Like

do not disable hpet, its snake oil and can cause more harm than good. Here is a link that gives a good explanation

1 Like

Intriguing. So it’s possible increased frame rates are reported, but perhaps not because of a genuine performance boost, but a different clock is used to calculate FPS?

You would need an external, high speed camera to capture video footage in that case. Set up a test scenario, and run through it multiple times, with HPET on, and off, and compare results, using the external video captured to verify.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.