Turbo Engine Condition Lever

#pc
Microsoft Store version
Not in Developer mode

On the Cessna Grand caravan before SU6 you could use “Mixture axis” and map it to bravo throttle axis to control the Engine condition. Now it doesn´t work. We need a “engine condition” axis on the mapping menu.

Bravo throttle quadrant

second this. Just notice the existing binding is not working and no luck finding a new binding for this in the control settings.

3 Likes

Now it’s just a three-position clickable switch, which completely defeats the purpose of having a lever at all. Someone wasn’t thinking straight on this one. Voted.

11 Likes

i was wondering what they meant by “Added turboprop condition lever implementation” in the release notes. unbelievable.

Want to make it 3 position only? fine. just keep it on an axis, with 0-30% off, 30-70% low and 70-100% mapped to high.

3 Likes

MODERATOR EDIT:
This post merged into this topic.

Where ist the axis for the condition lever??? It used to work with the mixture keybindings/levers?. How can that not be noticed?

5 Likes

Just trying the King Air post update and I can’t move the condition levers with the usual mixture axis binding on my TQ6. Can’t seem to find a new axis to bind to either

1 Like

Yup same here, previously the mixture dial adjusted this control.

Now I have to manually fiddle about with the virtual knob like some kind of Neanderthal.

4 Likes

I can see what they tried to do but it’s not good. It should be reverted back to its original operation.
They made it, in the caravan, so that you could click it to off, low and high as opposed to dragging it. In doing so, they basically broke it. Either that or I’m just not figuring it out.

2 Likes

I have noticed the same. Very annoying. I do hope they will fix this ASAP!

1 Like

Yep, same with my setup. I use FSUIPC7 and I can’t find a “condition lever” to bind the controller to, only mixture (and other things).

The good news is, after starting the engine I normally pop it into high idle and never touch it from that point on, so doing it in the cockpit manually is a workaround (I hope - won’t be able to test it until later).

2 Likes

Sadly disappointed, but I have faith in the developers. The “clickable” condition lever probably sounded good but fails to consider the users with peripherals like the Bravo throttle quadrant. If I were flying with just a joystick or Xbox controller, a clickable Condition Lever might makes sense (easy to set)… To those with hardware, it takes away from the ability to use that hardware. (this might be a good example of why catering to the XBOX audience upsets people so.)
I think it should work both ways and make it an option: Axis or clickable. With all the good engineering that is going into MSFS, I am pretty sure they could do that. I have faith they will get it sorted. Developers, if you are reading this… You guys are doing great. How about a little love or workaround on this issue for the people that bought hardware.

10 Likes

I don’t have this issue. Is it perhaps that my controller mapping has it right now, but if I were to delete it then I couldn’t put it back?

I’ve had two flights in the Caravan so far, and both times it worked as I expected it to. I had my physical lever all the way back when I started the engine, when NG came up to 12% I then moved the condition lever forward to low idle, and the engine burst into life. I taxied out, then moved the lever fully forward for takeoff.

1 Like

Wow, come on Asobo. It takes 5 min of research to identify how a condition lever correctly works, ie as an axis. The hard part was actually done, implementing the new turboprop logic to respond to condition lever inputs. Adding a mappable control axis should be the easy part!

Maybe I just don’t have the patience of others here, but I’m I’m getting kinda tired of every fix ending up half baked, requiring more additional fixes down the road. I’d love to be surprised with something that just works correctly first time.

13 Likes

I te4sted mine briefly this afternoon. My mixture lever will kick it into low idle and start the fuel but it doesn’t look like it goes into high idle. For that, I need to push it forward in the cockpit. And thus it goes.

1 Like

Hmmm, remind us what hardware you have, and what axis is that bound too?
My Logitech TQ Condition axis lever is also now non-functioning.

Very rare for me to have any issues (one or two CTDs aside). Not a biggie, but still. Why on Earth did they change it?

Then you don’t have the update, because after the update IT DOES NOT WORK, because there is no axis programmed in the code. Check in spad.next.

2 Likes

I definitely have the update, and I don’t use SPAD for my primary controls, only my Logitech gear currently.

Virtual Fly TQ6+.

I’ll check the binding tomorrow, but it’s the same as I had bound yesterday, and since day 1.

Could you please share which bind is selected in your controller settings?
I would like to try as I can’t find any that work.

From memory it’s probably mixture.