Turn radius using X52 yaw axis

I barely can follow the taxi center lines on the airports with every aircraft because the turning radius is huge when I use my X52 rudder axis for ground steering (assigned to rudder).

Even when the assisted steering is enabled it’s nearly impossible. I need to break until the planes are right before stopping to turn them around.
Last planes I tried were the C152, C172, Skyhawk, TBM930 and CJ4.

Any fix for this?

What you do is manually edit some cfg files. In the systems.cfg files of each plane, you want to enable differential braking by changing the differential_braking_scale line to “1” so that you can combine twist steering with the brake to apply the brake only to the inside wheel.

The second edit is in the flight_model file. You want to widen the steering angle on the nosewheel contact point. In every plane I’ve edited except the Icon, that point has been point.0. All wheel points have a “1” as the first parameter. The third parameter is the lateral distance from the centerline, so the nose/tail wheel will have a “0” there. Once you have the right point, find the 8th parameter - that’s the steering angle. Where to set that angle depends on the geometry of the rest of the gear points. A little high school trig is required. Luckily, I have the ones I’ve edited listed in a file so that I can redo the edits every time Asobo restores their #'s - I’ll list those at the bottom of this. If you need any other planes, let me know. You can PM if you want.

But before you start, remember the two rules of editing stock files:

  1. Make a backup copy.
  2. Make another backup copy.

Caravan, 60
C172, 50
Bonanza , 55
Cap 10, 70
DA40, 50
DA62, 50
Extra, 75
Icon, 45 (point.2)
King Air, 55
TBM, 50
XCub, 70

THANK YOU for this! I was finding the aircraft (specifically the C172) unsteerable on the ground, until I found this post.

If you assign nosewheel steering to the same axis as the rudder, it makes everything much easier!