Turning on Vsync in MSFS SU10 disables FSR

If you think you have FSR working with an AMD GPU you might be surprised to find that it is disabled.

I’ve got both an AMD CPU & GPU (5900x/RX 6800).

I can reproduce it at will with the following steps;


  • MSFS SU 10 vsync is off
  • Configure MSFS SU10 for FSR:
    • set to full screen mode
    • set resolution to a value less than the native resolution of your monitor
    • set rendering to 100
  • Turn Fidelity Super Resolution (FSR) on at the driver level via AMD Adrenaline sw utility

Reproduce problem:

  1. Fresh reboot after set-up
  2. Start MSFS SU10
  3. Start a short flight (less than 1 min is fine)
  4. Press Alt-R during flight & verify FSR is on (green checkmark next to FSR option) & press Alt-R again to exit
  5. Exit short flight
  6. Go into MSFS settings
  7. Toggle Vsync on and apply settings (assumes vsync was off initially)
  8. Press Alt-R and at this point FSR will be not working (yellow checkmark next to FSR option)

Exiting MSFS and rebooting and then going back into MSFS will get FSR to work again (most of the time).

This is very frustrating if you want to use vsync. If vsync is on initially when you start MSFS FSR might work for the 1st flight at most and then gets disabled.

Can a few people with an AMD GPU pls try the steps above to see if it recreates the same problem.


Now that you mention it, I think I did notice my sharpening go to zero at the same time I was messing with refresh rates during some benchmarking. I didn’t really investigate it further.

Intel CPU, RX 6800XT GPU.