TUTORIAL: Show Other Applications and Whole Desktops in VR

Well done, may I ask, anyone using the reverb G2, it stutters so much, it looks so good, not sure am I running to high graphics? lol.

I have a 3090 + 9700k, im a bit confused. Ill drop them now, but lmk if there is something i can disable that has helped.

    • I am so impressed this is amazing. I love little nav map in the cockpit!

Hi there,

Yes, there could be something wrong with your setup. I have a G1, 7700k + 1080 Ti at medium/high settings and I can run even OVR Toolkit.

Try to follow @CptLucky8’s tutorials, they should give your experience a boost. :+1:t3:


1 Like

I found it. MY render scale with the G2 was set too high. it looks, stunning. Amazing. Flawless. And stutters lol.

I dropped it to 70 but I find that it just doesnt look that good. OpenXR native runs better for me.

I will double check but we CANT run OPENXR and this right, we need steamVR to be the main one?

Yep, you need the SteamVR layer to use OVR Toolkit–no way around it.

Is there anything whatsoever available for the native WMR OpenXR runtime? Performance is key and I SteamVR isn’t as good.

We were able to use the WMR overlay (WMR start menu) in the beta to open apps inside OpenXR. It was amazing but somehow the update broke it. There are workaround like opening it before loading into the cockpit

Win + Y to activate and then Win key to open the overlay. Try it in the MSFS menu first as it currently breaks inside the cockpit.
It’s strange that nobody is aware of this WMR functionality as it is soo good for siming. You are able o open every app as 2D window inside the cockpit without additional program. But nobody cares about this at the moment apparently as I’ve opened threads about this without any responses…

EDIT: I created a bug report in the forum for the WMR people to upvote if they want to see apps in VR again: WMR start menu overlay crashes VR mode


I can’t get this to work in full screen. Whenever I alt+tab to the OVR window it just shows the sim, but if I alt+tab back to the sim I can see what’s supposed to be in the OVR window. When I’d use this in P3D I had to run in windowed mode to make it work properly, and it was fine, but running MSFS in windowed seems to lead to CTDs in VR. Are you using full screen or windowed?

For real world flying I use Skydemon. When trying to open it in VR as “classic app” in WMR “cliff house” sometimes it opens in VR and sometimes only on the 2D (normal monitor) desktop. When it opens in 2D only, in VR I have still the window open but the window content is just black or presents Skydemon application icon. When I click on it in VR, it results in “Loading circle” visible in VR and opening another instance of Skydemon on the 2D monitor only.
When Skydemon starts every time it displays a window for conditions confirmation which is visible on 2D screen only and requires pressing Enter, what I do.
Sometimes it works in VR properly, I can interact with the program with the mouse or VR controller. But sometimes it acts crazy, like going to sleep or not being visible in VR.

I tried this, but setting the current OpenXR runtime from WMR to SteamVR completely ruined my performance, the sim is unplayable now. Unfortunately there is no way to undo this change. I even uninstalled and reinstalled SteamVR, this setting is permanently set to SteamVR now. How do I reset it?

Probably a good way is to start reading the official docs?
VR Welcome Guide! - Virtual Reality (VR) / General - Microsoft Flight Simulator Forums

Thanks for the advice. Couldn’t find anything there that would help me (I admit that I prolly just don’t see it, I’m not a computer expert). Just to make sure, I’m talking about the last image in the first post of this thread. I challenge anyone: set the option “Current OpenXR Runtime” to SteamVR, and then try to undo it. Not even uninstalling/reinstalling helps…

Sure there is no undo, but look at this another way: SteamVR has a button “set me as OpenXR”, maybe the other headset driver application you’re using also has an equivalent… and if not (say Oculus) the answer is in one of the lined topic in the discussion I’ve linked above (and it is also posted in many discussions in the forum when using the search feature).

OMG, that was it. I would have never figured that out in a million years. Within WMR portal, under settings, there is “set up OpenVR” that resets this setting within SteamVR (go figure!). Everything is back to normal now. How it is possible that there are SteamVR options that cannot be undone unless you use another software (without any warning to the user), and how it can be that choosing SteamVR as your runtime can reduce MFS fps to 1 (no kidding) are prolly questions for another day…

1 Like

Yes, I have tried Steam runtime and have reverted to the Oculus runtime “it just works with the Quest 2”
Can run my steam VR games with it also.

I had tried going down this path but my performance in MSFS when using SteamVR as the runtime is horrible. It was with the Rift S and it still is with the G2. So, any app that relies on SteamVR is no good for me to try to use to bring a desktop into MSFS.

BUT, I was working with another guy on Facebook to try to figure out how to do this and I finally realized that it’s not all the difficult. It’s not ideal, as it brings in a whole desktop (monitor) rather than individual apps and you have to switch the mouse in and out of MSFS. But it works with no performance penalty and does not need Steam.

The other guy made a video of basically how to do it (you use the desktop from WMR), with some good tips. He uses a voice activation program for some things (like switching the mouse), but there are other ways.


I have RTX3070 and Reverb G2.
I tried to bring the desktop from the Cliff House to MFS2020 VR using the method from the video but I have huge performance drop from 32 FPS to around 26 fps.
I wonder what is different between our setups, that you don’t suffer performance drop.
My settings:

  • render scale in the sim 70% TAA
  • OpenXR 100%

Maybe I’m running out of VRAM?

I’m getting smaller impact of having the desktop in the cockpit when I bring my setting down to:

  • render scale in the sim 60% TAA (lowered from my default 70%)
  • OpenXR 100%

I use the follow me option but it doesn’t work very good and its the hole monitor screen not just a single app. I want to bring in ipad/foreflight only. I have a non steam addition. So could you explain or make a video of this process where you bring in only the app not the full screen?

is there a way to see other applications but without using Steam VR but WMR?

Yep, just press the start menu button on your controller and open the application. Before the recent OpenXR update, MSFS will crash back to 2D (exiting VR), but since that update I don’t have that issue anymore. Some others still have that issue though. You can test your luck.


Using the G2 with WMR can you have more that one window in the VR cockpit. When I tried to open a second window it closed the first window.

When I use OVR Toolkit and SteamVR I can have as many as I want but can’t get a stutter free experence in MSFS. On X-plane this is a non issue and just trying to find a solution to do the same on MSFS either with WMR or SteamVR.