Two Issues Since Latest Update

New to the sim and have the following issues since the latest update:

I can not re-start the engine in the Cessna 172 (not the G1000 version)

The fuel selector switch in the Cessna 172 will not turn, it just turns yellow

Although I can see the name boxes for aircraft, I can’t actually see the planes

Any suggestions regarding these issues?


Hello Doug,

since you are talking about stuff before the update, I’ll assume you’re running the sim on PC.

You can try going back to the controls the way they used to be, by going to General options → Accessibility → Cockpit interaction system (change it from ‘Lock’ to ‘Legacy’). That should bring things back to the control scheme you’re used to.

For the multiplayer models; they just might take a while to load in, or maybe the other players are flying fairly far away?

1 Like


As MortThe2nd advises - Multiplayer aircraft can be seen in the sim for anything up to 50 miles away or so so you’ll not see anyone until they’re virtually on top of you. To check you CAN see other Multiplayers why not have a look at the World Map - zoom in on a region and you should be able to see others in the sim depicted as green aircraft traces. Go to a busy airport where you see these and take the drone for a spin to go close up and check.
If it turns out that you can’t come back here and tell us and we’ll try some other stuff.

Thanks for the replies. I’m not as worried about seeing the aircraft as I am about the non-starting engine issue and the inoperable fuel tank selector. If I can get these two to work, we can then tackle the multiplayer aircraft issue.

I am totally new to this sim (using a pc) and very short on computer tech stuff so take it easy on me :slight_smile:


Doug, did you get this sorted (tank selector and Eng Start in the 172) by doing what Mort advised with the Mouse back to Legacy Mode?
I would echo his advice that for PC users the Legacy Mouse interaction is the preferred way to manipulate everything in the cockpit.


Options > general options > accessibiliti > cockpit interaction system
Select LEGACY and save changes (apply and save)

Also select default mouse profile.

Go to options > controls options > mouse
Select default profile > apply and save.

Move cursor to fuel selector and use mouse scroll wheel up/down.

1 Like

I went back to LEGACY mode and it fixed the knob issue with the mouse. It did not, however, fix the non-starting C172 engine issue. I tried out a couple of other aircraft and was able to start them both. They were turboprops. Anything else I can try regarding the C172 engine?


You have to install the updates from the Content Manager .
After doing that it will be like before the update 5.
Go to your Profile ( icon up at the top of the interface) click it than you will see Content Manager.

Hi Doug,
Sorry to hear you’re still having trouble firing up the C172 Classic.
A few things to check;

Check Fuel quantity in tanks
Battery Master - On
Fuel Selector Switch - Both
Fuel Cutoff Switch - IN (small red button just above Fuel Selector Panel)
Mixture - RICH (Fully pressed IN)
Throttle - Open 1/4 Inch
Ignition -Magnetos - BOTH and then turn to START.

If that doesn’t work - Hit CTRL + E whilst scanning the lower panel to see if anything changes during the Start process.

In order, here’s what I have:

Fuel Quantity - all tanks full
Battery master is on
Fuel Selector Switch - Still doesn’t work with the mouse - stuck on right wing tank
Fuel cutoff Switch - pressed in
Mixture: Set to full rich
Throttle - Open 1/4 inch
Ignition: First checked both mags, then both then tried START - Engine just cranks, doesn’t start

Haven’t Done the CTRL+E thing yet, will try then next


Do I have to install both the Premium and the Deluxe updates?


yes you need both.

Will do…Thanks.


I have the same issue. I have flown the C172 for some time before and I am experienced with it. I have trouble with engine start as well as toggling the fuel selector. Even LEGACY did not help

I know it’s cheating in a way - but (it’ll help with diagnosing the problem) how are you guys getting on if you just hit CTRL + E ?
Make sure the Handbrake is on before you do.