UI broken and reset user settings - Gaming Services update

MSFS does not launch with this workaround, it redirects to MS Store to update Game Services. Please explain how you go about launching the game?

It comes down to the same problem …

It works for many people, try again and follow exactly the steps Ten Patrol gives us…

I hope you get there.

1 Like

Thank you very much, but I went back to the old version of Game services (2.50.5005.0). When launching MSFS I am redirected to MS Store to update game services to version 2.50.18001.0.
The problem revolves around.

Any words from Asobo yet?

someone from the FlyTampa team mentioned that they have spoken with Asobo regarding the KLAS download/install problem - which is presumably related to the GaminingServices update as well.

However, this likely is not an Asobo problem as GS is developed by Microsoft… Thus any fix will have to come from Microsoft and I’m sure some of the game developers (Asobo, and any others than have been affected) will beta test the patch before it is released to the public.

Honestly, I’m not expecting an update til Monday or Tuesday.

2 Likes

An interesting finding from this morning. I was flying in a group of three this morning as part of my trip from Cape Town to Scotland (shameless plug below). Both of the other guys had not experienced the issue. The only thing we could distinguish between our setups was:

I am using the game pass version and regularly check the MS Store Manually for updates (Experiencing the Bug)

The two other guys had the full MS Store version and had not yet refreshed the MS store updates manually (Cautioned them not to do so!)

This is not working for me. The gaming services download file is not an executable. There is no right click install option for it. I am running as admin.

They are just lucky…gameservices is updated automatically…even when you disabled automatic updates (like me).

1 Like

Try Link2 as TenPatrol mentioned above… i could do it (and i am far from an PC expert).

That’s the same file. I am waiting for a fix. Luckily, I have four other sims which do what I expect them to do.

Just tried the fix and it didnt worked for me either, guess Ill have to wait until this gets fixed from the Asobo Side.

it is not for Asobo to fix the problem, but for Microsoft.

3 Likes

Worked for me! Controls settings recovered, instead Pilot Profile and Logbook seem lost.

That’s why I prefer to wait for an official fix.

1 Like

For more than 40 hours, a problem that seems to affect a lot of users. And so far no reaction or statement from Asobo or Microsoft? At least I haven’t read anything about it yet…

4 Likes

Thanks Joburgal.

I mentioned a couple of times above already, it would be useful if everyone else experiencing this issue could confirm whether they have a ‘Buy to own’ license, or a GamePass license, too. My suspicion is that this issue is affecting GamePass users only. If true, hopefully that won’t affect the priority of a fix.

1 Like

I have Game Pass but I bought the game. And have the issue too.

Same bug with MS store version.

What is interesting is that my UserCfg was saved when I last closed FS
image

WITH my Graphics settings that I reset each time and the last time I started FS:
image

Each time I now start FS, it asks the “first time” questions, and my Graphics Terrain LODFactor is 1 (or 100). I like having it at 135 to avoid buildings jumping after landing at Lukla.

So, my graphics settings ARE saved on my system, but the GS bug tells FS NOT to use them!

Just wanted to say thanks very much for working this out mate, much appreciated.

For anyone else who is struggling to apply the workaround, follow TenPatrol’s instructions in the post above. It worked perfectly for me.

The workround should not affect your online profile or history, rather it will temporarily fix the way MS Store Gaming Services checks and validates your MSFS license when starting the sim.

2 Likes

I have ‘Buy to own’ license ; Premium Deluxe.
And the bug!
Paying more to get the bug: what a Privilege. I am so POSH…

1 Like