UI broken and reset user settings - Gaming Services update

Uff you can call me coward, but playing with Windows Reg and that kind of stuffs are not one of my strength. I don’t fell really confortable changing things on that as I don’t know what implications may have on my computer. I’m gratefull to all of you guys who provide here solutions to the bugs, but there are things that medium user should never have to do in order to be able to enjoy a product he has payed to.

2 Likes

Where can I open a ticket to Zendesk? I have already voted the post

Thanks

https://flightsimulator.zendesk.com/hc/en-us/requests/new

3 Likes

Yes, after zero issues with settings since day1 of the product, I ran the latest UK World Update etc the other day, and on sim launch am now presented with the demand to “Set my experience”. Funny, I thought I did that on first installation!

This is now happening with every launch. The sim is not retaining many preferences such as assistance, on screen prompts, graphics choices etc etc and even seems to be losing controller profiles I have created.

There are plenty of other threads on this issue, yet I see no definitive answer, nor the simple admission the problem exists. I’ve seen threads were reinstallation is suggested! Really?! Get real. Not happening.

Something in the update process would seem to have undone what should mostly be one time only setting selections, so I expect a proper solution, not the suggestion to reinstall :joy:

Some discussions suggest these settings are cloud hosted, but I have no issues with my connection, which puts doubt on that one.

So, as suggested by the OP here, I had the same thought - if an aspect of the install has become flakey thanks to a mandatory update, it would be nice to give the user the choice of loading settings from locally hosted files instead of relying on some process that does not appear to be stable.

I’ve logged a ticket on this but am not holding my breath, based on the experience of previous tickets I’ve logged. :unamused:

2 Likes

Hello @Dav3Ruk, after the latest UK World Update 3 the sim started normally for few times, yesterday suddenly I was presented with the demand of “Set my experience” and this is now happening with every launch. There is no definitive answer. I have tried couple of them with zero success. I have also logged a ticket following many tickets, which until today were never answered. I can’t imagine that we are the only users who are experiencing this. Should we create a new topic?

TenPatrol’s workaround is doing the job. You must keep the services off until there is an offficial fix, otherwise the gaming services will be updated again.

2 Likes

I’m indeed having this problem. Waiting for a fix. Hopefully not too long of a wait

2 Likes

Same here. Access is denied.

2 Likes

I’m still running the older Gaming Services 2.50.5004.0. How do I stop or block it from updating until this gets fixed?

Keeping the gaming service disabled would be your best bet so it can’t be updated.

I take it from Services.msc. Will MSFS2020 still run?

My ticket was just requalified as a bug report. No ETA, no suggested actions until resolved. This leads me to believe that they really don’t know what happened.

Since the application that broke everything for us is from Microsoft, I don’t know if there is much Asobo can do besides ride MS’s butt and encourage them to fix it. :confused:

Same problem here, it is not Asobo fault, but Microsoft…

It’s up to Asobo/Microsoft to fix this, not have people try to do workarounds even if the workaround works.
When you pay for a product, generally you expect it to work out of the box, without having to set the sim up every time you fire it up.

6 Likes

Very likely expecting a fix in the next new hours should be resolved before Wednesday at the latest.

1 Like

Well you’d think a thread with over 500 replies might get some interest, so I’m unsure if creating a new one would help or not tbh.

Couple of other thoughts that come to mind…
-seeing others have their zen desk ticket categorised as “bug”. It’s not a bug, it seems to be A version of Gaming Services that’s not fit for purpose. If it’s not that I can’t wait to hear what it really is, given the number of people that have the issue, a common version of that component, and timing all fits in. That said who can blame us for believing that is the root cause, as there is no official comment on the issue one way or the other. Appalling lack of customer respect.

-the thoughts emerging that differing versions of Gaming Services are out there. Until now I’d imagined they standardised on one version and any variations would merely be due to deployment capacity and timing. If, as someone has suggested, MS are targeting systems with specific versions, that deserves some explanation. If true, at its most ludicrous, it could be seen that we are an unwitting test bed for whatever code they decide to bang together. I don’t recall signing up for that or offering my testing time for free.

Given the lack of communication my thinking is to keep hitting Zendesk, and reference the version/date of Gaming Services, perhaps referencing this thread too. If they can’t be bothered communicating it’s only natural that customer noise levels will increase, whilst patience decreases.

9 Likes

Thank you!!! It worked like a charm! :laughing:

1 Like

I couldn’t agree more!

If they can’t be bothered communicating. The question is (( Why Why Why)) I would like an answer please.

2 Likes