UI broken and reset user settings - Gaming Services update

same problem :frowning:

I am confused by your post: two versions and both the latest version? One for MS store and one for Steam?

1 Like

Game Services 2.50.18001 is the latest version. Of course for PC.

Sorry, but this site is not an official MICROSOFT site, where does this SOFTWARE come from?
Thank you

Thanks so much…that helped!
When MS will fix that, please provide the steps to restore everything. Thanks

@TenPatrol Thanks for the workaround! :+1: Beers heading your way… :beer: I have MS store version.

MSFS does not launch with this workaround, it redirects to MS Store to update Game Services. Please explain how you go about launching the game?

It comes down to the same problem …

It works for many people, try again and follow exactly the steps Ten Patrol gives us…

I hope you get there.

1 Like

Thank you very much, but I went back to the old version of Game services (2.50.5005.0). When launching MSFS I am redirected to MS Store to update game services to version 2.50.18001.0.
The problem revolves around.

Any words from Asobo yet?

someone from the FlyTampa team mentioned that they have spoken with Asobo regarding the KLAS download/install problem - which is presumably related to the GaminingServices update as well.

However, this likely is not an Asobo problem as GS is developed by Microsoft… Thus any fix will have to come from Microsoft and I’m sure some of the game developers (Asobo, and any others than have been affected) will beta test the patch before it is released to the public.

Honestly, I’m not expecting an update til Monday or Tuesday.


An interesting finding from this morning. I was flying in a group of three this morning as part of my trip from Cape Town to Scotland (shameless plug below). Both of the other guys had not experienced the issue. The only thing we could distinguish between our setups was:

I am using the game pass version and regularly check the MS Store Manually for updates (Experiencing the Bug)

The two other guys had the full MS Store version and had not yet refreshed the MS store updates manually (Cautioned them not to do so!)

This is not working for me. The gaming services download file is not an executable. There is no right click install option for it. I am running as admin.

They are just lucky…gameservices is updated automatically…even when you disabled automatic updates (like me).

1 Like

Try Link2 as TenPatrol mentioned above… i could do it (and i am far from an PC expert).

That’s the same file. I am waiting for a fix. Luckily, I have four other sims which do what I expect them to do.

Just tried the fix and it didnt worked for me either, guess Ill have to wait until this gets fixed from the Asobo Side.

it is not for Asobo to fix the problem, but for Microsoft.


Worked for me! Controls settings recovered, instead Pilot Profile and Logbook seem lost.

That’s why I prefer to wait for an official fix.

1 Like