UI broken and reset user settings - Gaming Services update

For more than 40 hours, a problem that seems to affect a lot of users. And so far no reaction or statement from Asobo or Microsoft? At least I haven’t read anything about it yet…

4 Likes

Thanks Joburgal.

I mentioned a couple of times above already, it would be useful if everyone else experiencing this issue could confirm whether they have a ‘Buy to own’ license, or a GamePass license, too. My suspicion is that this issue is affecting GamePass users only. If true, hopefully that won’t affect the priority of a fix.

1 Like

I have Game Pass but I bought the game. And have the issue too.

Same bug with MS store version.

What is interesting is that my UserCfg was saved when I last closed FS
image

WITH my Graphics settings that I reset each time and the last time I started FS:
image

Each time I now start FS, it asks the “first time” questions, and my Graphics Terrain LODFactor is 1 (or 100). I like having it at 135 to avoid buildings jumping after landing at Lukla.

So, my graphics settings ARE saved on my system, but the GS bug tells FS NOT to use them!

Just wanted to say thanks very much for working this out mate, much appreciated.

For anyone else who is struggling to apply the workaround, follow TenPatrol’s instructions in the post above. It worked perfectly for me.

The workround should not affect your online profile or history, rather it will temporarily fix the way MS Store Gaming Services checks and validates your MSFS license when starting the sim.

2 Likes

I have ‘Buy to own’ license ; Premium Deluxe.
And the bug!
Paying more to get the bug: what a Privilege. I am so POSH…

1 Like

From offical ms site.
If now I paste link directly from ms site - line expire after 20 minutes.
I don’t have time to edit my “workaround” every 20 minutes :joy:

btw.
I’am ex Wargaming Community Contributor so you can trust me and I know what I’am doing :wink:

1 Like

TenPatrol how to run GameService as admin? I can’t

I also have the full Premium Deluxe version purchased from MS, and I also have the bug

1 Like

Powershell not gaming services

Thanks Revamped.

Bollox, it’s worse than I thought then.

I know where I’ll be going to buy the full version of MSFS from when my GamePass trial runs out, and it won’t be MS Store… :unamused:

@TenPatrol thanks for the help and link 2 buddy. It’s nearly bedtime in Australia and I need shut eye before I open power shell. I would very likely mess up big time if I tried it now. It seems your method is working for some here. It’s definitely worth a shot.
Cheers

1 Like

But as i run gaming services installer he told me that it can’t be installed cause i’ve to run as admin. And he give me this string:
Add-AppxPackage M:\Download\Microsoft.GamingServices_2.50.5005.0_neutral___8wekyb3d8bbwe.AppxBundle

You will still need Microsoft Game Services, even from Steam … It’s a Microsoft game.

2 Likes

@Schummy1
Have you entered as admin through power shell? It’s important. Let us know how you go.

1 Like

Yes, I’ve opened power shell as admin.

I don’t want lo lose my logbook :angry: :angry: :angry: :face_with_symbols_over_mouth:

@msfsuser

Agreed mate. @TenPatrol gets 100 out of 100 points. Many thanks for the help.

1 Like

Yeah I guess so. But then I wonder why everyone isn’t affected by this bug, and only some of us (otherwise, presumably this thread would be overrun and they’d have had to make a major announcement)?

There must be a specific condition that triggers the bug for some, and not for others. According to the release notes, the Gaming Services update was intended to provide localised content, so maybe something to do with regional settings somewhere?

I Hope that ms will fix it fast next week and retsore our daraus via Cloud.

Till this Moment i did it twice nothing Work or i got a instant Crash. So no more fs for me