UI broken and reset user settings - Gaming Services update


Hmmmm… I’m not a programmer or IT guy. Just a lowly avionics engineer and R/W pilot who hasn’t flown real metal for 7 months with this lousy pandemic. I use this sim to stay sharp. Better than nothing.
Maybe ask someone here why you are having this problem. Wish I could help you.

Maybe you are right, also the installation directory. MSFS for me is on the D:
If Game Services only checks the default Microsoft App directory, there’s a good chance we’re all in the same situation.
We would need other people to confirm their installation path, so that we are safe.

Regional issues … I don’t think we’re on the same versions.

Of course, I guess I am not an expert.

I’ll bet, with my luck, a hot fix is released right after fixing this problem using @TenPatrol method. Then that hot fix breaks my sim again… :wink:

I’ve to try cause I’ve a NON default install directory

1 Like

You will need to disable services.
Please read again carefully.

1 Like

@TenPatrol you’re more than welcome! Will give it a go in 8 hours. Much appreciated :grin:

It worked! Many thanks for the help!

1 Like

I have FS installed on D: , not on C:

1 Like

I’m sorry, I have disabled the services and followed the whole procedure (twice).
But that’s not really important at the moment, given the general impact.

Thank you.

So if I understand this correct, all your settings are stored on a cloud and all of us who have this problem have to rely on MS to fix this? I always thought its saved on my machine. So weird that the sim acts like you’re firing it up the first time and asks you for the settings over and over…

My logbook seems to be ok.

1 Like

Hello Just wanted to say the work around worked for me thank you. I would also be careful on buying add ons from the market store as I purchased Las Vegas add on yesterday and it would not download. Restarted MSFS 2020 and it then said I did not own it and needed to purchase again.

Does anyone know if the workaround works after reboot the pc?

My logbook seems lost :sleepy:

sadly, R.I.P.

My logbook is still OK:

but my Pilot profile not: Top data is correct

But 26 of the 29 details underneath are 0 or N.A

Before applying the TenPatrol workaround I even updated Windows 10 to 20H2 as well as all the APPs in the STORE.
I have rebooted several times but with no solution!

I also purchased “Buy to own” licence and also experiencing this issue exactly and immediatelly after updated to the latest version of Gaming Services. So I’m sure that this problem is wide spread and your suspicion is wrong. :slight_smile: So my suspicion is that this affected almost everyone.

My logbook is safe by now. Flying hours in every aircraft are stored locally and I did a backup already, but don’t know if it is possible for the logbook.

By copying the directories in another drive. I hope I could restore them if they are resetted.