UI broken and reset user settings - Gaming Services update

Same here. Filed a bug to Zendesk.

Same issue here.
Until yesterday, I enjoyed community flight after UK update w/o any problem.
But when I try to start msfs2020 as usual in this morning, suddenly msfs asked the initial question. and my setting was lost, I’m frustrating especially to the lost of control setting. I regret if I had stored the setting files…
(key assign, sensitivity curve of joystick, rudder, etc…)

1 Like

Same here…Gameservices is the one who did this, was flying in the morning okay in the afternoon gameservices updated and i now have this problem. Uninstalling gameservices does not fix it.

This is the second time gameservices brakes something, a few months ago it did too.
After that i selected that win10 does not install updates in apps automatically…but it still did today with gameservices.

Your control settings are safe…i thought i lost them too but you just have to select the control en just beneeth is select wich setting you want (don’t select "default"your settings are in the memory

Can someone check if the following steps roll back the Gaming Services app to version 2.50.5005.0? That’s the version I’m running, and FS works fine with it.

  1. Open PowerShell as admin

  2. Enter command:
    get-appxpackage Microsoft.GamingServices | remove-AppxPackage -allusers

  3. Then this command:
    Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.GamingServices_2.50.5005.0_x64__8wekyb3d8bbwe\appxmanifest.xml" -DisableDevelopmentMode

  4. Restart computer and start Flight Simulator 2020.

  5. If the command under point 3. fails, just reinstall the gaming services app with start ms-windows-store://pdp/?productid=9MWPM2CQNLHN.

­
If you try this, let us know if it worked.

1 Like

I didn’t lose my profile, but I lost all my settings too, and I need to set them everytime I open the sim. Just argh.

at step 3 i get an error message…can not find path

ah dump me…didn’t read point 5…

i did this two times this afternoon…unfortunately every time the problem making gameservices version is installed…so no change to roll back.
I also set back a system recoveryfrom yesterday… no luck

Btw… This can’t work, cause STEP 3 is referencing the older version’s manifest on the local disk. That is simply not there because we have the latest version already installed. :wink: Any better workaroun there?

HINT: We need to find a way how to get older package from MS online repository, OR you upload an archive of your version from your local disk, so we can download it, unpack, copy to target WindowsApps folders and try to registar it as you described. There are more than one folder btw.

I want to jump in. I was forced to download the latest Game Services from the MSStore to even get MSFS to boot. Now I’m getting the same thing. My profile is intact, thankfully, but ALL my settings have been and continue to be reset every time I boot the sim. Thankfully it keeps my control profiles, so I just have to switch to them but it saves nothing else and just resets.

@SteveX77 Yea I’ve still got these files, but I’m not sure whether I’m allowed to share files like this. Will see what I can do in that regard.

@MrSquishieUK I think it’s better to wait for a fix from the devs. Messing around even more with the system settings might actually do more harm than good.

1 Like

I’ll check if locking local config files (after initial config) with READ ONLY attribute on the filesystem will keep setting despite the initial start setup will try to overwrite them…

I’m sure you’re not because of MS copyright covers it. :slight_smile:
And yes, they should fix this ASAP because this effectively avoid us from using the sim smoothly and already throwed away lot of our prerciselly finetuned settings… :frowning:

That doesn’t help, i tried this already.

Right…we should have a saving option in the sim to get the finetuning into safely. I lost mine already 4 times since August (a few times because of NVDIA drivers update and two times because of this very fine Gameservices…

1 Like

I have set back a windows recovery file from just after world update 3…after startup Gameservices is being updated immediately even that i have set automatic updating to off.

There is just no way to escape from MS forcing us to download and install updates that will break something.

1 Like

the worst is that such critical “hidden” update arrive saturday morning CET, just for the weekend :frowning:

2 Likes

Same here with having to reconfigure MSFS after installing the Gaming Services update this morning.

what’s more… I purchased FlyTampa KLAS (Las Vegas) from the marketplace store and while I was able to make the purchase (with email confirmation), the actual install files won’t download and the scenery doesn’t show up in my profile. After restarting MSFS there’s no indication that I had even purchased the scenery already…

1 Like

Glad I came across this thread… been going out of my mind with this for last 30mins

3 Likes