Unable to click rotary knobs

:green_circle: Required

Have you used Developer Mode?
No
PC Specs:
10700K, 2070S, 16 GB RAM, SSD
Aircraft:
Any
Area of the World / Flight Plan:
Any
Airport (If applicable):
Any
3rd party addons you were using at the time (Mods/add-ons/community content)
Bijan season mod
Peripherals:
Honeycomb Alpha, Bravo, T-rudder
Feedback/Bug Description:

I updated to the beta test version of the sim and noticed that when I try to click on rotary knobs, for example the lower right button on the G1000 panel to scroll through waypoints, it starts to rotate the button really fast and I’m unable to just click the button. I’ve only flown in VR since updating so I don’t know if that’s the issue but I would like to know if this is a known problem or if there is something wrong on my end.

There is a setting for legacy switches and buttons in the cockpit. Make sure its set to that.

I will try it when I get home from work.

Doesn’t need to be on legacy. In fact aircraft/cockpits that are not legacy FSX ports should be used in modern. There isn’t really any purpose for legacy if not using legacy ported planes; some used to believe that was the only way to get rid of the tooltips but there is a specific menu option for that.

As for OP -
The knobs are definitely clickable in the beta not in VR; I can’t comment on VR specifically though, but I’ve done plenty of flying with the G1000 in the beta and do exactly what you’re mentioning with the waypoints every single flight (modern cockpit).

Double check content manager to be sure all updates are installed for the various sim packages as well as the G1000NXi.

Cheers

You’re talking about a totally different setting with a LEGACY position. :blush:
Vonzeigler was referring to the newer LOCK vs. LEGACY mouse setting.

2 Likes

Thank you! I had no idea that Asobo introduced a new setting for the cockpit interaction that I had to manually revert. It should be the opposite, but well well…