Unable to download MSFS2020 after uninstall

I am running Windows 10 (latest update) and used FS2020 successfully since Nov 2020. A few CTD’s but without too many hic-ups. I have been away from the computer for a month and on my return fs2020 went into an immediate CTD without even starting up. I did not even get a chance for the last major update to get installed. A black window for 10 seconds and gone. After spending hours trying to resolve that, I finally uninstalled MSFS2020 wanting to reinstall it. I went back to the MS store and figured out how to load the installer at 1.6 GB and pressed Launch to make things happen. But nothing did except the same recurring black screen as if it were going to start but instantly disappearing. I tried finding answers in the flightsim forums but without much luck.

Launch or install?

Try sign out and in from the Microsoft store and Xbox app. Restart your computer after.

Topic moved into #bugs-and-issues:performance for installation problems.

First I installed. After 1.6GB it switched to Launch . I then pressed Launch and shortly after a black screen appeared and faded a way back to normal monitor. Looking at MSFS 2020 path nothing showing in Packages , store etc

where is official and community folders installed?

It was installed on C Drive /users/my name/appdata/local/Packages/Microsoft.flig…/localcache/Packages

After that nothing. Used to have Community and onestore which I moved to my G drive before uninstalling MSFS2020. The idea to speed up installation by putting Onestore files back with new install.

xbox app and gaming services up to date?

all appears to be up to date.

You cannot move these files. FS2020 will not know where they are.

Having the same issue. Couldn’t launch MSFS so uninstalled, however now getting Code: 0x80070424 when trying to install. Sad…!

1 Like

Download wuauserv.zip

Run file named w10-wuauserv.reg and click “Yes”.

Run file named w10-bits.reg and click “Yes”.

Restart system

w10-wuauserv.reg ran okay.
Couldn’t get w10-bits.reg to run successfully.

Still stuck on install as you can see. I’ve tried pretty much everything i’ve seen on forums :frowning:

All up to date ,including latest windows update…!

Turn off AV software.

Same result , i had already tried with both firewall and AV off :frowning:


1 Like

SUCCESS! I contacted the Zendesk for support and after an hour I received a contact and asked me to provide information to analyze my system. after providing them with data they came back with in an hour having identified the issue as a .dll file. the suggestion to fix my issue to go to Taskmanager/Startups and disable all non-MS apps, reboot and go back to Launch flightsim. I did that and it worked. The download started and included all updates.
My Hat is off to the support team for providing this excellent support and all within a couple of hours. Amazing. There are apparently 4 apps I had that msfs did not like and might have contributed to CTD’s.
I hope your issue is resolved as easily as mine.

1 Like

Do you mean disable all non MS Autostart Programms in Taskmanager?

Some programs can prevent Microsoft Flight Simulator to load fully. To investigate, please do the following:

  • In the Windows Search bar, type “Task Manager
  • Select Open
  • Go to the Start-up tab
  • Disable all non-Microsoft apps
  • Reboot the computer
  • Try launching Microsoft Flight Simulator again

source https://flightsimulator.zendesk.com/hc/en-us/articles/360015999539-Loading-issues-stuck-on-loading-screen-long-loading-times-stuck-on-black-screen-etc-

1 Like

I do. Under Task Manager look for Startup, and start by disabling all Non MS apps. Reboot and Launch. That worked for me on then first try. To find out which app is the culprit, enable one of the disabled apps and reboot and see if MSFS works. Keep doing that until the app causing the conflict is identified. Good luck.

1 Like