Unable to get past the spacebar screen in VR

cant seem to be able to get past the press spacebar to center the screen in VR. is there any extra steps needed?

Is the spacebar mapped correctly for you? What happens when you press it?

1 Like

If you have modified Control Profile, the new update today won’t include the Default controls… which include the Recenter key.

IMPORTANT: Bind the Re-center Key BEFORE starting VR Mode!

SOLUTION: Press ALT-F4 to exit the sim and bind CTRL-TAB for VR Mode Toggle and SPACE for VR Recenter.

3 Likes

i managed to get past the centering screen but i get a black circle on the screen now. is there a solution to that?

Same problem - launched the sim, enabled VR mode, then had a message I could not get past saying press [VR centre] to continue - no indication of what button it is, and obviously I have not mapped one (yet).

I used Alt-Enter to drop out of full screen mode but ended up closing the game and will try again, mapping the control first. Would have been the next thing I tried but had time to come and find this thread in the time it takes the sim to load back up :slight_smile:

Would be great if it were possible to press Esc to back out of the ‘centre VR’ page in such circumstances.

1 Like

I have one too with the Rift CV1

Try this - it works,

Now all I have to do is to try and figure how to bind the VR keyboard presses to the HOTAS One.

No problem before but in VR they just won’t bind the VR contryols.

Can’t even get the mouse to zoom in or out, nor can I allocate a button to bring up the toolbar in VR which is a real pain.

Could somebody please tell me how to bind any keys to the VR mappings?

Clicking on these and also F12 for defaulting the bindings doesn’t do anything…

3 Likes

Exactly same problem here trying to enable VR mode with Oculus Link

1 Like

@GoRonger, @ChristianDan885
You can’t changing the binding in the VR mode screen shown in the above screenshot. You have to go into the main “Controls” section and bind them there. You can search for “VR”, I found that the easiest way.

It is a bit misleading, but that screen above only shows you what the current binds are, like a summary page.

Hope that helps!

3 Likes

OH! thank you!
It worked :slight_smile:
thanks!

I can bind the keys and they work except for the Recenter key, it still doesn’t work? Anyone got any ideas? It driving me crazy!!

Not having a default Recenter Key when you enter VR the first Time without a warning - mindblowing.

1 Like

This baffled me too. But the reason is because all Beta testers are forced to install the entire build, resetting to default key-bindings… thus including the VR Recenter keys (Spacebar) and VR Toggle (CTRL-TAB). No problem with defaults.

Then, once they released to public… any user with a custom profile would likely have conflicting existing keybinds (spacebar and Ctrl-Tab) and the Sim won’t overwrite them.

This would have been a non-issue, had they included a ‘Cancel’ option after entering VR. Tough to catch all these bugs, especially when it relates to Customized user controls.

This how far I go when it comes to VR! It won’t don’t nothing when I try to switch to VR? I been at this for almost 3 days now! Plz any help?

1 Like

Hello Everyone, I’m having the same issue. I’ve tried binding new keys in the control panel, but nothing
is working? has anyone figured this out? When I open the control panel, the only key bind that I
have is the right mouse button. NOTHING else is assigned? I’m confused.

Thanks in advance, Jim

I got it to work by binding onto a button on my yoke instead of the keyboard

1 Like

Hey guys, as was pointed out some posts above, you can’t do any binding assignments in that VR control panel. And if you still jumped into VR, you then couldn’t make it past the screen which demanded you to center the viewpoint.
What you have to do is to visit your controls/keyboard settings. Search for “VR” in the keyboard mapping section. There you will find these and will be able to assign them just as expected.

1 Like

Correct!!! That screen ONLY shows what IS bound. I finally got it!!! Thanks Guys!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.