Unable to Launch game for Months

Ok, since the first major update for MSFS 2020 I have been unable to run this game. I thought I would leave it be, but after 2 more additional major updates later and I’m still having this issue. So now I’m at a loss. I’ve been dealing with this for hours and literally no way to fix this. At first I thought a solution was to unplug all monitors except my main monitor. This seemed to work only for the initial update/install. However launching the game again never works. After the 2nd splash screen I get a CTD. EVERYTIME!

I have posted 2 other threads on this. Here & Here.

Ultimately event viewer always results in…

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x5fda3fe4
Faulting module name: MMDevApi.dll, version: 10.0.19041.546, time stamp: 0x287a0c1e
Exception code: 0xc0000005
Fault offset: 0x000000000001b34b
Faulting process id: 0x37e8
Faulting application start time: 0x01d6e6f5f47f6957
Faulting application path: E:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\System32\MMDevApi.dll
Report Id: 547edb4b-8b90-4af9-9999-793cebcf5895
Faulting package full name:
Faulting package-relative application ID:

I’ve tried everything BUT doing a complete OS re-install and this seems completely unnecessary.

System specs:

Intel Core i7 9700k
32Gb DDR4 Ram 3200
x1 250GB Samsung SSD (Sata III) (For Main OS)
x1 1TB Samsung Evo SSD (Sata III)
x1 1TB Samsung Evo SSD (M.2)
Asus GTX 2080 TI Strix (RIP Bought this in November of 2019… at full price :sweat_smile:)
ASUS ROG Maximus XI Hero

I’m at a loss for words and just about to give up on this flight sim. I really just want to fly in MSFS2020. But just doesn’t seem applicable to me anymore with my current system.


How old is your hardware?

E.g.: for me cyberpunk was always crashing. My mainboard firmware was 1.5 years old, I updated my mainboard firmware and it worked fine.

If it does still not work after a clean OS re-install then I think it’s your hardware (which includes firmware)…

But keep in mind, a mainboard/bios update could be dangerous if you don’t know what you are doing!

With that exception code, you might check to see if DEP is turned off for MSFS.

“DEP or Data Execution Prevention is a Windows in-built system-level memory protection feature that protects your system from damage caused by viruses and other security threats. However, some programs are not compatible with DEP feature in Windows and cause a 0xc0000005 error. To turn DEP off,

  • Sign in to Windows as Administrator
  • Press ‘Windows+R’ and type sysdm.cpl. Hit Enter
  • Click ‘Advanced’ tab and then click the ‘Settings’ button
  • Click on Data Execution Protection tab and click ‘Turn on DEP for all programs and services except those I select’
  • Click ‘Add’ button and then browse and add all the executable (.exe) files that are causing the issue
  • Click ‘OK’
  • Restart the system and try running the programs”
1 Like


This is the result of trying this with FlightSimulator.exe

Though I will admit this is not something I had pursued, so I definitely appreciate the help.

1 Like

Sorry it didn’t help. Clutching at straws at this point. Hope you get it fixed.

1 Like

Ya I did, just update my MB Firmware to the most recent one, unfortunately this did not solve the issue. I will most likely need to do a complete OS re-install just to play this game again, which is rather disappointing to say the least.

Thing is if that fixes it then it was never a fault of the sim without trying it you won’t know. I have seen posts in the past that re-installing the OS fixed this for them.
I assume by this point you have run sfc /scannow as admin on command prompt to check windows files.


I had this issue before and i know your frustration believe me.

What you have to do is reset the app, go in settings on windows 10, then click on app, scroll down until you see “Microsof Fligh Simulator”, under the title of the app there’s “advanced options” (I’m Italian so the translation couldn’t be correct), then click on reset.

If that doesn’t work, Uninstall and then go to Microsoft store install Microsoft Flight Simulator, then and this is important! On Microsoft store click on dots beside your picture account, then click on Download and update, then click on get updates.

In my case i followed all these steps but not “get update” and it wasn’t running, when i clicked on get update i got an update for flight simulator, then it worked very well, this happened after a huge update in September, and if you solved be sure to swtich in the flight simulator options (once is running) and switch in flight model from legacy to modern, because i got problems after the update and my planes were not controllables.

I hope you solved!



Ya, Unfortunately that command did not work for me either and still get CTD but do appreciate your help nonetheless.

Unfortunately this would not help in my case as I have the game on Steam, which the Verify and Repair function does the same thing. However, it just re-installs the whole game. Thanks though for the potential alternative method though.

1 Like

Full OS reinstall would be my next move. Good luck.

Try going through the steps mentioned here: https://www.notsupporting.com/exception-code-0xc0000005/

If it doesn’t work out, then you might need to re-install windows from scratch.

One thing - might be clutching at straws - but I didn’t see it being discussed in your three threads: overclocking.
I’ve seen many posts here and noticed myself with my rig that FS2020 often reacts badly to overclocked systems, even if they are running perfectly with other software. Also overclocking puts a lot of extra demand on the power supply. So in case you haven’t tried already, run your system completely without OC (with my system it was the RAM modules. When I tried running them at D.O.C.P. with 3600 MHz, FS crashed. Then set them on Auto at 2800 MHz and FS was stable. Now run them on around 3200 MHz. )

1 Like

I can only imagine the frustration.

Open a log to ASOBO with these details…Perhaps someone is familiar with it and can start pointing your in the right direction.

This is a long shot but, I was having CTD on second screen after an update and someone suggested that I limit the frames to 60fps through the Nvidia Control Panel – I did this and it solved the issue after restarting my computer and booting up the game again.

  • How many Monitors are you using?
  • Are they all identical?
  • Are there other “games” you use without these problems?

Maybe you already tried this but I’d take these steps:

Unplug your Monitors except your main Monitor of course.
De-install your Graphic drivers using DDU (this way you ensure a clean installation). When you use DDU make sure you reboot in Safe-mode before uninstalling.
Reboot in normal mode and download (the latest) Nvidia drivers. At this point it doesn’t matter if they are the optimal version.

Then I would do a FULL uninstall- and reinstall of FS2020 before launching it. I know this is painstaking but this way you can make “sure” FS will install a clean version. At this point I wouldn’t attach the other monitor(s) yet. Also make sure you relocate your Community folder if you use it.

After installing FS (again… I know) fire it up :crossed_fingers:.
At this moment I can’t think of any other solution or cause (apart from Hardware failure). I hope this works

Goodluck and keep us informed

Do you have set your paging file to custom or so?
If yes, set the paging file to system managed size.

Yesterday I try this for me (32GB Ram) and set it on 512MB. After that FS CTD several times.

I remember something like that happened to me but so many years ago…

Steam recently gave me problems with vr in a few game for example and a way for resolve this issue was Uninstall steam included any registry trace and then install it and download again the game.

Once you Uninstalled steam, go on start in windows and type “regedit” (without quotes), but before open it right click on the title and open as administrator, you’re now into registry, scroll down click on software location and you will see under folders, find steam and right click on it and delete it (remember before Uninstall steam and only after that you can remove the registry trace).

Now close the registry window, don’t touch any other thing!

Now go in your “computer C” or other letters depending on your primary drive is located, and on 64 bit programs search your steam folder and delete it (don’t delete it before Uninstall!)

Now restart the pc and download steam, once installed download Flight simulator 2020 and then let me know if worked!



I am having the same issue. I have unintalled, reinstalled, DDU of display drivers, cleaned out folders in USERS, deleted the regedit entry for MSFS and I still cannot get past the ASOBO screen. No idea what the issue is. It was running fine for a month or so. Keep us updated.

Out of interest when you run sfc /scannow did it come back as clear no errors or issue’s found? as sometimes it will find an issue that it can’t fix and extra steps are required.