Unable to launch MSFS from Shortcut

I’m now not able to launch MSFS from the Desktop icon or from the Windows Start bar. I can’t find a way to launch the programme at all.

It was working fine last time I used it a couple of weeks ago, after applying the World Update 3. But now I can’t get it to start.

I checked, and I am logged into Xbox.

Any help would be appreciated thanks.

MSFS was bought from Microsoft store.

I’ve done nothing to the PC or MSFS since it did last work a couple of weeks ago, other than the ‘routine’ windows update.

I did search topics to see if this issue is already covered but couldn’t find this issue.


Hi John, Welcome to the forums! I’ve moved your topic into #bugs-and-issues:performance which is also for the issue you are having.

What happens when you try to start the sim?
A few things to start.
Are your Window’s updates current?
Did you try signing out of both X-box and the MS Store, and then signing back in?

Thanks for your replies. I’ve now got MSFS launching and running again thanks to your help.

When I clicked on the Desktop icon/shortcut to launch MSFS, nothing happened at all. I tried right-click on the shortcut and “Run as administrator”, but that also resulted in nothing - like the shortcut was not connected to anything. I tried launching from the Windows Start menu but again, no response.

Eventually I got to the Microsoft store window that appears when an MSFS update takes place, and noticed that the update bar was about 50% along but stuck and with an ‘error’ against it. I pressed the ‘error’ message which then went away and I then pressed the continue download button and it carried on with the download and completed. On completion I pressed the play button and MSFS launched as per normal. I then closed and tried the normal start via the desktop shortcut and it was working again.

So, it appears that the inability to launch MSFS was due to the update being hung in mid-stream.

I hadn’t actually initiated the update, this is why I was originally trying to launch MSFS so that I could action the update. When I first tried to launch MSFS I was not aware that MSFS was already in the update process.

Also not sure why the update hung/error but it might have been because I didn’t listen to the advice to clean out the Community folder before updating… One of the things that I had tried to fix the launch issue was clearing the Community folder but this hadn’t worked but I left the folder empty… maybe then when I later found the hung update error, with the now-empty Community Folder the error was removed and the update could continue ???

Anyway, back in business again, for now at least…

Thanks again

1 Like

Solution by OP.