Unable to set Elevator Trim and Flaps

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version? No

Are you using Developer Mode or made changes in it? No

Brief description of the issue:
ELEVATOR TRIM: Level flight impossible as elevator trim immediately returns to Neutral position after Nose Up or Down command, Neutral default of trim is +5° and not Zero, issue occurs in the following aircraft A320 NEO, Cessna 152 and the Cessna 172.

FLAPS: The default position of the Flaps is 10° and not Zero? when set to zero, + 20°, or 30°, by controller or in the cockpit, it immediately rolls back to +10°(default position)

Both issues have been tried on 3 separate controllers with the same result.

As part of my investigation, I have viewed the issue in the following aircraft…. A320 NEO, Cessna 152 and the Cessna 172.

A Clean install has been executed, but the problem still exists.

The community folder has been emptied with the same result
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:
• Gigabyte Nvidia GTX GeForce RTX 2060 [Display adapter]
• AMD Ryzen 5 5600X 6-Core Processor 3.70 GHz
• Crucial P1 1 TB CT1000P1SSD8 Internal Solid State Drive-up to 2000 MB/s M2
• Corsair CMK16GX4M2B3200C16 Vengeance LPX 16 GB (2 x 8 GB) DDR4 3200 MHz C16 XMP 2.0 High Performance Desktop Memory Kit,
• Evga 650 Bq, 80+ Bronze 650W

Build Version # when you first started experiencing this issue:
MSFS Build
Windows Spec : Windows 11 Home, version 21H2, OS BUILD 22000.376

Same Issue here.

Two quick checks…

  • Ensure that your flight model is set to MODERN

  • Check the assistance menu and be sure all flight assists are OFF

The most common reason for unresponsive/uncommanded control is when the computer (AI) is given control or is “Assisting”.

Also on some planes, the autopilot is ON by default even if there is no autopilot in the model:) like L-39C “Common” - try to press the button you usually use to switch off the autopilot during your flight to check this.

Good morning, Flight Model set to ‘Modern’ can’t find OFF position? but set Assists to Middle Ground seems to be working ok, will check further to day, and come back to yo ,

There is no off. You have two choices, modern and legacy.
Ensure it is set for modern.
As mentioned, the AI assists will cause this, as the AI is trying to fly the plane.

I indicated OFF for the AI assist options. Not the flight model. OP chose to use one of the presets instead.

As you drill down into the individual settings, you can chose to turn off specific assists which will give you a “CUSTOM” preset.

1 Like

Noted! Thanks, all working fine now, will work om my knowledge for these setting.
Thanks again

Noted! Thanks, all working fine now, will work om my knowledge for these setting.


1 Like