Unable to start Piper Warrior from Logitech Switch Panel

I’m not sure if I’m posting this in the right place. I’ve been away from MSFS for a couple of years with eye problems.

I’m now trying to u e a Just Flight Piper Warrior that I purchased a while ago with my Logitech Yoke and a Switch Panel. I can’t start the engine from the Switch Panel, because, using the Panel, the sim Magneto switch only stays in Start setting for about two seconds then reverts to Both.

I believe this a known issue affecting various aircraft, and can be resolved with relatively simple config changes involving Start Torque and Start Delay. But I can’t find where to meke the changes. I believe it’s to an engine.cfg file, but I can’t find that for my Warrior.

Can anyone help?

This is what I use for the Warrior II.

And don’t forget these:

I’m not sure why I don’t have a corresponding “MISC” in the off state. Perhaps it wasn’t needed, I don’t remember, but it probably wouldn’t hurt to set that to “0” also.

Thanks for the help.

Sorry to display complete ignorance, but what am I looking at? I assume it’s some sort of Logitech configuration software, but I’ve never seen it before. I have something called Logitech Gaming Software installed, but it refuses to detect any devices.

More help need, if possible. :wink:

1 Like

The Warrior is designed for a realistic start which means you need to crank a while before it catches.

Unfortunately the logitech starter sends a single pulse which only cranks the starter for a short time.

If your after a simple fix Just Flight provide a file in the documents folder for the Honeycomb that has the same issues called engines.cfg_HoneycombYoke to replace the standard engines,cfg . This file should work for logitech.

1 Like

That’s SPAD, an external program for poking away at the sim behind the scenes, as it were.

If you aren’t using that, you would need to use the Logitech driver software. I’ve never really used that, but essentially, as long as you have the mixture fully forward, you have the selector by your left leg set to a fuel tank with fuel, and you have the fuel pump on, the engine should start.

My guess is you don’t have the fuel pump on.

Or this. :wink:

Is there a way to configure that with the Logitech drivers? I’m guessing not, so maybe that one step would need to be done with the mouse in their case.

The single pulse is the issue - if I watch the magneto key in the cockpit while operating the Switch Panel rotary, I can see the key dropping back to “Both” before the engine starts.

I saw the Honeycomb file and wondered if it might help. OK, another dumb question. Where is the original engines.cfg file? Perhaps I was having a bad day yesterday, but I failed to find it.

I don’t use SPAD, but will investigate.

I’d really like to fix this - using the mouse will break the immersion, which is the whole point of shelling out for the Switch Panel in the first place!

SPAD is a lot more fiddly to configure, as you have to do everything yourself, or find an online profile that gets you 90% there, then you tinker with the rest. I didn’t find the Warrior particularly fiddly, and I’m happy to share my profile with you if you go down that route. I believe SPAD has a try before you buy, where you can use the full version for 14 days.

https://www.spadnext.com/download/download-spad-next.html

I’m really sorry to continue asking dumb questions, but where is the localcache folder that your address starts with?

I’,m beginning to tear my hair out now. I cannot find a localcache folder that leads to anything like what you’re showing. The only folder that looks remotely like it is in the aircraft’s folder inside an MSFSPackages/Official/OneStore folder on my Programs drive. I can’t even find the MSFS installation…

If it’s relevant, my wife gave me MSFS2020 as a Premium DIsk Edition, and I have to run it with the lead disk in the PC. As far as I remember I bought the Warrior from the Marketplace.

C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

It’s not a dumb question. It’s dumb not to ask questions. :slight_smile: :+1:

It’s not a dumb question. It’s dumb not to ask questions. :slight_smile: :+1:

You’re right, of course. Thank you.

I feel a little better anyway, because I had found that folder. Yippee!

However, the subfolder structure is quite different, and when I eventually get down to the only Piper Warrior folder I can find, all it contains is state.cfg, and all that contains is two entries related to elapsed time, one on the Hobbs and one undefined.

The same is true of all the other aircraft, except for two which contain CAMERAS.cfg. I did mess about with camera settings on those two aircraft before I fell ill.

Is this possibly because I haven’t actually flown anything for ages? I only picked up MSFS again a few days ago and I’ve been obsessed with getting the Yoke/Switch Panel etc. configured and the engine started. I’ve run the engine, but only on the ground.

Not sure what to do now.

It really depends on where you have the sim installed, and also whether you are using the Steam or MS Store version.

So for me, the sim is broken up thusly.

C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.33.8.0_x64__8wekyb3d8bbwe

This is where the sim executable is installed. When you use the XBox application to prompt an update of the sim, and you get that ~2GB download, this is where it gets stored. This is not where the bulk of the sim is installed, which is where you would find planes, and airports etc.

C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe

This is the folder which has the “LocalCache” folder, amongst other things. There is also a folder that contains you logbook, and controller configurations. This is where you found the “state.cfg” files, one per plane.

All of the folders except one are “Junction Points”, which means the folders are actually elsewhere on the system. For me, presumably because I chose to install the sim on my “D” drive, they actually exist in:

D:\WpSystem\S-1-5-21-3738441901-1295518950-3516428421-1001\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe

The long number is the SID of the local user account that has MSFS installed.

image

This is also where you will the following file, which points to where you have the sim proper installed.

C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\UserCfg.opt

At the end of this file, which has graphical options for the sim, it has the location of the bulk of the sim, which for me is:

InstalledPackagesPath “D:\Flight Simulator”

This is where you will find the “Community”, and “Official” folders. Non-Marketplace purchases are stored in “Community”. Marketplace purchases will in “Official/OneStore”.

1 Like

Many, many thanks for that explanation. I will work my way though it and see what I can find.

I don’t know what version I have. It was originally installed from disc, and subsequently updated from within the simulation. I have spotted OneStore as a subfolder in some of the paths I’ve followed, so perhaps it now equates to an MS Store version.

I will beaver away.

1 Like

If it was a disk version then it won’t be the Steam version, so your paths will largely mirror mine, depending on whether you installed the sim on C or D.

From the FlyByWire help pages:

To find the Community folder that MSFS is using, please follow these steps:

  1. Go to your General Settings in MSFS and activate Developer Mode.
  2. Go to the menu and select ‘Virtual File System’.
  3. Click on ‘Packages Folders’ and select ‘Open Community Folder’.

This opens the Community folder in a Windows Explorer.

Thanks, both. I think I’ve found everything.

Unfortunately, it hasn’t got me anywhere! I copied the Honeycomb file into the aircraft folder (in Official), renaming it appropriately. But still no start.

I’ve tinkered with the starter time and torque, which seem to be the relevant settings, with no joy.

For the moment, I’ve come up with a workaround, which is to bind Engine Autostart to a spare button the throttle quadrant. So I can go through the switch settings, finish up by setting Magnetos to Both, and then hit the Autostart.

Not ideal, but it gets me there.

Any other ideas gratefully received, else I will tinker some more with the settings, probably over the weekend, and report back.

1 Like

OK, well I tried tinkering.

Changing starter_time in engines.cfg seems to be doing absolutely nothing at all. The engine cranks for about 2.5s, whereas using Engine_Autostart it cranks for well over 3s before firing.

Something else is presumably controlling the crank time.

Any other ideas out there?

Well, switching from both to start and back rapidly a couple of times will keep the engine cranking and eventually it fires, but that is not necessarily a good solution as it is both unrealistic and bad for the Logitech starter switch,

Yes, that occurred to me, but I couldn’t get the knack of catching it before cranking died. I gave up, as I didn’t much like the idea for the exact same reasons you describe.

I think I’ll raise a ticket on JustFlight and see if they can help. They did provide the Honeycomb file, after all.