Unexpected VR Performance boost: Try this for a smooth VR experience

After a fresh MSFS installation I optimized my VR Settings (OpenXR: Motion Reprojection On) until a got a reproducible constant and smooth framerate (checked with OpenXR: Frame-timing-overlay window).

One day the performance suddenly changed and I got stutters and low framerates during VR flights.

After some investigation I found the reason for this issue and it was really unexpected for me. Before the perfomance loss I had switched the MSFS PC GRAPICS GLOBAL RENDERING QUALITY from MEDIUM to ULTRA. Would you expect that this 2D setting could cause a performance loss in VR?

I switched the PC GRAPICS GLOBAL RENDERING QUALITY back to MEDIUM and after a restart of MSFS the VR performance was great again!

If you are a VR Pilot please check if you could reproduce this behaviour on your machine too.

  1. Go to “General Options/Graphics/PC” and set GLOBAL RENDERING QUALITY to MEDIUM
  2. Restart MSFS
  3. Start a new flight in 2D Mode
  4. Switch to VR and check if your VR performance increased

Please share your results

My System:
PC: Ryzen 5600 with 32 GB Ram RTX 3070 with HP Reverb G2 Headset


I run the main panel de-tuned to reduce secondary GPU load for VR operation. Dropping the Full Screen Resolution to something like1600 X 900 changes the Global setting to Custom. I want all the GPU muscle going to the headset, not the main panel.


=========== Update ================
@OxyOfEmpire requested that I perform another test but this time start the flight in 2D and then switch to VR. My original post (below) was from starting the flight directly in VR. So these test results are measurements during the VR portion of the flight only, but this time the flight was started in 2D. After takeoff I waited until I had wheels up and flaps up before switching to VR.

My results are unusual. In the chart below the results are identical to the results from my original post so the framerate didn’t change no matter if I started the flight in 2D or VR.

However I did notice something very unusual. My VR flight that started from the ultra 2D settings was very clear like normal. However my VR flight that was started with the medium 2D settings was not clear. It looked like I was flying with low settings. I was sure I was going to get higher framerates from this test because of the low visuals but as you can see my results weren’t better. The visuals were much worse but the framerates didn’t change. That’s strange! I checked my VR settings after the mdeium flight and they didn’t change. They were my normal settings so I’m unsure why I got poor visuals with no improvement in framerate.

Anyway, I hope this helps your cause @OxyOfEmpire ! I think you found something worth digging deeper on.

=========== Original Post ============
Sorry but there’s no difference :grin:

Specs: 5800x, 6900 xt, 32 GB RAM, Reverb G2, motion reprojection off

Here’s my measurements using CapFrameX. You can see the average, 1% low and 0.1% lows are identical. Note I did a restart between changing from medium to ultra.

1 Like

Thank you for testing! What resolution is your display? This might have an impact.
My full screen resolution is 3440x1440


I have the same resolution, a 4K 55" LG CX. Sorry, I see mine resolution is a little bigger at 4K.

One last question: After your restart with Ultra 2d Settings. Did you also start your flight in 2d and then switched to VR?

I always switch to VR before the flight starts in 2D.

This could be the reason you didn’t noticed any difference. I guess many VR pilots set their 2D Settings to Ultra because a VR able system should easily handle that. My point is that if someone starts a 2D flight in Ultra that might cause unexpected performance issues when switching to VR mode. If my observation is true, it could be helpful for other VR pilots to set 2d to Medium. Any confirmation of other users might set Asobo aware of a potential bug. I already posted the observation to the issue tracker.

Sorry. But settings to medium in pc mode, reset en start again,
for me has no effect IN VR mode (settings in VR mode are also medium).
My system is 9700k and 2080 GSX.

What settings have you changed in Nvidia Control Panel?
Did you also set VR settings to default?
I have experienced that when increasing VR settings (to a level where I finally get stutters) and dial back - it seems bad performance sticks. If I set VR settings to default, apply&save and then raise my settings again it works fine.

I tried also, but impossible to reproduce.

Please note that I updated my original post with new results as you’re requesting here. But I didn’t find what you’re expecting. It’s weird!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.