Uninstall and reloading MSFS

Would you describe in greater detail the following statement you made?

My brakes settings looks like your except that both of those side by side rectangles show the same axis.

Update: Ah, you mean the rudder axis, I think. Yes, the second box should NOT have anything in it. Click on the box (or double click), Clear Input, Validate.

Also, would you try setting the brakes to Joystick L-Axis Y and Joystick L-Axis X as shown in the screenshot above?

So there is something I didn’t mention before.
When I select the X and Y (no plus sign) axes I get this error message so I naturally assumed either the + or - axes need to be used.

So this time I ignored the error message and selected the X and Y for Left and Right brake respectively.
After doing so those slider bars that I asked about in the followup post appear below the brakes as I expected they should.

At first after applying and saving the config, the rudder axis stopped working. Nothing worked when I just saved and resumed my flight.
So the next time, instead of just resuming and going back to the aircraft, I shut down the sim and then restarted the flight.
Now the rudder pedals in the sim are working again but still no joy on the brakes even though the sliders are operational with the axes that MS said is not recommended to use.
Initially the aircraft I used to test the brakes was the JF Piper Arrow, but just for grins I went back to a default Cessna 172. Same result…still no toe brakes.

So MSFS is recognizing the pedals and the toe brakes as indicated by the movement of the slider bars in the assignment window but for some reason that X and Y movement is not getting translated back into any of the two aircraft I used for a flight.

I am convinced that it’s a MSFS issue with the extensive updates I went through after not using the sim for 8 months . What is confusing is that these pedals worked fine in the summer of 2022 right after I initially installed MSFS 2020. Then I installed the JF Arrow, but don’t remember exactly when, and all worked fine for the short time I used that aircraft before moving back to Xplane.

So the big mystery is why MSFS sees the X and Y axes in the config but those axes are not recognized in the aircraft. I have been testing the operation of the brakes by looking at the pedal animation or starting a takeoff run on the runway. There are just no toe brakes.

I feel that it has something to do with some updates, perhaps Windows updates over the last 8 months or more than likely the extensive automatic MSFS updates when I started it up after many months of not using it.
That is why I feel I need to start over with a fresh install of MSFS.

As an aside, the short white bar for the left brake is due to a sensitivity setting (extremity Dead zone was set at 9%). That is easy to fix.

Axis Error

OK, so now there is possibly another clue as to what is going on. Your Right Brake dialog box shows an Action Type: On Press with the Warning: selected axis input is not recommended for this action.

My Right Brake dialog box does NOT show an Action Type:
Right Brake

My mouse and keyboard profiles show Action Types with “On Press” and “On Release” but not the pedals.

What make and model of pedals do you have?

I think you may have some interference or confusion going on with all the other hardware you have. You ARE making progress. It is obvious that you now have the correct axes assigned, as you can see they work the sliders. It is the Action Type that is giving you grief now, but that shouldn’t even be a selection with the pedals.

You could try deleting the entire pedal profile and creating a new one. It wouldn’t take much time.

I’m also wondering if you somehow have a driver assigned to the pedals that is causing MSFS to think it is a different type of device?

You might also disconnect the pedals and reconnect them before creating the profile to make sure it is seen by MSFS as a new device. You may have to remove the Windows profile for the pedals, too, then start completely over as a new device.

I will check the action type thing when I get back home.
The rudder pedals are the Slaw Viper RX which are supposed to be plug and play other than using the calibration program that comes with it and is supposed to be used rather than the windows calibration. I have been in touch via email with Slaw and he is adamant that these pedals are not the problem and that they will work completely in MSFS 2020. He says there are many of his customers who are using them with the flight sim.
I have unplugged all devices other than the mouse and keyboard from my computer and tried running the config with only mouse keyboard and rudder showing in MSFS.
Slaw swears the algorithm he used is not the problem even though he says it is similar to a mouse algorithm.
These worked last summer when I first installed MSFS. The difference now is that a very extensive update occurred when I started MSFS after an 8 month hiatus.
Edit; I will again delete all profiles, unplug the rudder, start MSFS and then plug the rudder cable in and see what happens….again.

OK, things are starting to come together. I will research the Slaw Viper RX (I’ve never heard of that make/model).

Update: Wow, nice pedals! The following has no bearing on what we’re trying to do here, but it is unfortunate news from the Slaw website:

As of today, March 18, 2023, orders for RH Rotor rudder pedals are still being accepted.

Production of these pedals will be suspended at the very least. The suspension of production will take place, at the latest - in May. But it may happen sooner.
I’m sorry this happened. Unfortunately, we have no influence on the cost of parts for the production of rudder pedals.
Design of new devices and small-scale production will continue, at least I plan so.

I will post any changes here.
Thank you for being with us.

Yes I learned that from Slaw yesterday…these Viper pedals are awesome, but I would really like to be able to stop the aircraft in MSFS.

Yes, stopping the aircraft is important! :grinning:
It would be nice if slaw had directions on how to install to MSFS.

Update: I hadn’t realized until now that you have two threads going on the problem:

I see more of where you’re coming from now and why you’re so frustrated. You’d think Slaw could give you some help here on how the pedals are to be installed in MSFS.

I guess an uninstall and reinstall IS your only option remaining. It seems all else has failed. Have you tried getting in touch with someone using Slaw pedals on this forum? Perhaps a title like “Slaw Pedal Installation” or similar would get the attention of someone using the pedals.

Slaw doesn’t have MSFS 2020 but says

If you have calibrated the pedals with such
programs or with Windows, delete this calibration (restore default
values). Then calibrate the pedals with our software. Video
instructions are available on our YouTube channel. Perhaps this is
the reason.
In any case, if the pedals work in other simulators and Windows
detects all three axes, then the problem is only and exclusive in
setting up the MSFS simulator. It is also possible that some other
axes in your controllers “intercept” the brake axes.
Pedals cannot work in one simulator, work in Windows and not work in another simulator due to the >>fault of the pedals.

I have done the calibration with his utility and not with the windows calibration…been there… done that.

So with the supposed “plug and play” function of these rudder pedals, I get this after deleting all profiles, opening up MSFS and then plugging in the USB cable directly to a 2.0 USB port on my mother board.

I think I got that message when I first set up my CH pedals as MSFS didn’t have a profile preset for them at that time. Click Customize and see what happens.

Ok…I figured it out finally. Yay!!

There are two sets of Brake assignments in the MSFS list of controls…see image

I was selecting Left and Right Brake (sans axis)
Changing to the Left Brake Axis and Right Brake Axis solved the problem…too many options that I never noticed before.
There are obviously subtle differences in the two.

It’s obviously not really Plug and Play with MSFS.

It’s working in the default 172…now I need to test in the JF Piper Arrow.

Excellent!!

No joy in the Piper Arrow aircraft…no toe brakes in this add-on aircraft from Just Flight…
Rudder works but no brakes…

I will try some other default aircraft later.

Don’t have the Piper Arrow so know nothing about it. But it must be recognizing the old profile and not the new one. Reconfigure (if possible) or reinstall to see what happens.

Hold my horses…when testing it in the Piper I was looking directly at the pedals and looking for the animation movement and didnt try it while rolling.
It’s a JF aircraft animation issue.
The brakes work when the aircraft is moving, JF just didnt bother with the animation of the toe brakes.

OK, makes sense. :grin: A reinstall “might” fix that.

Problem solved and I have to understand that not all components are animated in some add-on aircraft.
You know what they say about making assumptions…

No need for the toe brake animation really. Perhaps JF decided it wasn’t worth the effort. Who really looks at that when flying?

It should be noted as a bug if it is not already, though.

I hope I was of some help to you. I know it took a while, but that’s sometimes what happens, as you probably know.

You were of great help. It got me to looking at my errors in using the config options of MSFS, which I am still learning. I guess I could reach out to Just Flight to see if that is a bug or a “feature”.
Thanks to you and everyone else who helped in getting me to understand how the config works.

1 Like