Update -> game studders

The update now creates studders for me (with and without TrackIR v.5.4.2). The latest NVidia driver (457.30) does not solve the problem either. Unflyable. Come on MS/Asobo !!!

Problem solved : it runs as usual after the last windows update or NET-framework update (11/13/2020). :wink:

So interesting I was also posting about it I have no stutters but my frames go down and up, not smooth, do not know …no fun right now.

1 Like

I was having the exact same thing since the previous update before that my sim ran smooth since release.
I think the game graphics might be glitched. Here a link to a post I made about it in the update discussion page might be useful to you too. Would be interested to see if it does the same for anyone else.

There is a noticable stutter every 60 seconds in free flight now. The stutter is massive in bushtrips now, frequently stalling the render piple for 650ms-700ms. This coincides exactly when the bushtrip autosave happens, but no file is written in free flight.

Given the similarity, I think they are also doing an autosave in free flight, but it is kept in memory or perhaps send back to the servers.

Either way, there is no reason for this to happen on the main thread ever!

Edit: See how bad this is in bushtrips. It happens every time on the minute (look at timer), every minute.

Noticed messed up ground texture (blurry) in flight close around the aircraft (A320NX) when looking from outside have not tried with the default A320

Just having terrible stutters from 40 to 0 fps every seccond, unflayable anymore…

Have you tried what I did in my post above in the link.

I have this weird Framrate stutter, so when I fly A320 and Wingview right no stutter and then left, Frame start to jump up and down, even lowered settings to lowest , no difference, outside Plane everything goes smooth. No fun flying… We will have to wait until it gets fixed, I will fly with another Simulator for now. I spent 2 Hours yesterday trying to figure out something, but no luck, changed NVIDIA SETTINGS, no change read in forum all the help etc. nothing changes, still have those framerate spikes, do not know how they call it , it runs smooth, but has some kind of jumps do not how to explain it :smiley:

I have a i9-10900k/rtx3090 playing on 4k. Even with frames up to 40-50 with ultra settings I was still getting stutters. Spent maybe 2-3 days moving stuff around. This morning I decided to lower my refresh rate from my monitor from 60hz to 30hz and BOOM!
Stutters went away.
I don’t know if that will help you but maybe give it a try. I have vsync ON with 60 frames locked.

Does this mean the plane just jerks a bit? I ask because what I experience is mini lockups. Can get several in a row and one can freeze the sim for up to 15 seconds. Each time it happens I get a typical PC sound. They always recover but it’s annoying.

I am pushing the sim though running 4k on 32" monitor. Settings are mostly high. None in Ultra.

Got a reasonably good system:
Intel i7-7700k
Nvidia 2080Ti
16Gb DDR4 3200

Installed on a 1Tb M.2 PCIe drive

Search YouTube for stuttering or micro-stuttering (two somewhat different symptoms). It’s basically the game freezing for what is almost an imperceptible amount of time but usually very frequent and with a pattern (micro-stutters) or for a few seconds, normally due to the game engine loading something or badly managing CPU threads, this can happen seemingly at random.

After patch 5 I started getting long freezes, maybe up to 3 or 4 seconds which I thought were almost CTDs (crashes to Windows’ desktop). Patch 6 made those long stutters/freezes actually trigger a CTD now, so it’s worse for me.

You can use this trick to figure out what’s going on: Open Windows Task Manager and make it “always on top”, go to the “Performance” tab and double click on any graph, that will give you a slimmed down version of Task Manager. Now open FS2020 and fly around. Keep an eye on the CPU, Disk, Memory, GPU usage when the stutters happen. With 16Gb of memory and playing in 4k I would suspect you are at about half the memory you actually need.

Tnx, EricGonzalezM

GOOD reply! Am considering buying 32Gb ram. Have to buy all though as CPU fans are in the way of two slots. Guess it’s more to do with devs optimising than my PC being faulty.


NOTE:I mainly fly the A320Neo atm. The stutter gets much worse if I get really active around the cockpit panels which is a pain cause that mostly takes place during the critical landing phase.

1 Like

I think you just pointed at your stuttering issue without even noticing (although I would still go for 32Gb in total eventually)

I suppose your motherboard has 4 RAM slots and the cooler is in the way of the 2 leftmost pair, and I also suppose you have 2 8Gb sticks one next to the other. In that case you are running your memory in single-channel mode. You’re basically bottlenecking your CPU to only be able to access one module at a time. Pretty much all modern motherboards require you to place your RAM modules in odd or even slots to enable dual-channel. So, for example your sticks should be in slot 1 & 3 or 2 & 4. If you then buy another pair of sticks and you don’t exactly match your older RAM, you should keep them in that same order (RAM A: 1,3. RAM B: 2,4).

1 Like

I have 4x16gb modules.

Do you think that was causing my stutters because they’re next to each other?

If you only have 4 RAM slots, you cant really go wrong :smiley:

On X299 or other HEDT system, there might be 8 slots, just consult the MOBO manual.

Yeah I only 4 ram slots.

Same here! Had none of that before and now there is sometimes small lockups that last from 2 to 5 seconds. Tried some tips from around the forum but nothing helps. Really unplayable for now.

If you have 4 slots and 4 modules, you are by default running in dual-channel mode. No way to mess that up. Just make sure that if you have two different pairs of sticks (different brands or different speeds) that they are not together and ideally that the faster modules use the primary slots. Your motherboard’s manual should give you an idea which pair of slots is Bank A and Bank B.

Problem solved : it runs as usual after the last windows update or NET-framework update (11/13/2020).

Really? Fixed it for you? I am not home yet need to check. Anyone else have it fixed after windows update?