Update 1.18.13 broke yoke axis input

Purchased sim → installed
Changed nothing (No settings, no profiles, no sensitivity, no drivers, no community folder)
CH Yoke worked fine, Sim ran great
Used for months (no problems)
On 7/27 ran sim, Mandatory update
Ran after update
CH Yoke buttons work, axis does not. (No throttle/mix/pitch/aileron/elevator)
CH Yoke axis work flawlessly in sensitivity section only

Not a yoke but I had a similar problem with my joystick … click on preset manager at the bottom of the page and then on to whatever your profile was previously and then try and select an input. At least that worked for me but I don’t have to use 3rd party drivers. If that still doesn’t work keep checking the yoke manufacturers site for an update

You have the exact same symptoms and mine also registered in sensitivity but it still had to be assigned, try on default and whatnot, doubleclick if necessary, you never know

I would start FS2020 and then unplug and replug your yoke to see if that solves the problem. FWIW

my mouse was set to ‘mouse profile’ by SU5 , nothing worked , changed it to ‘default’ profile , mouse works
check under your Yoke if there are more then 1 profile.

Same issue.

CH support in general here is an after thought.

My yoke after the update needed excessive pullback to raise the nose on takeoff. The rudder seemed less sensitive.

Seems I have to delete the profile or readjust the sensitivity AGAIN

Oh the pain.

May I ask if you ever changed the sensitivity settings of the rudder?

Found them second hand but they are extremely sensitive.

Again the axis is obviously not assigned to whatever profile you have and it won’t be unless you assign it even if that means a new profile, you must at least try the scan function! Fyi my joystick was no different the sim could see both axis’ without problem but they were no longer registered to the profile that they were originally assigned to.

Thanks for everyones input not sure if any one thing made a difference but Ill list a few items I found on varies online resources, hopes this helps out the next guy!
Ill edit if i remember more

Tried different usbs
Hot swapped USB before/after game
Connected yoke PC on/off
Turned online back on (was off)
Reset every possible setting in the game
Re-calibrated with Windows yoke/pedals
Uninstalled / Reinstalled entire sim
Uninstalled /Reinstalled CH drivers
Changed many in game settings with peripherals
^Disconnected/ Recconnected ie. mouse, keyboard, yoke, rudder varies times in/out sim
Created a new profile for the yoke with preset manager, change the name idk why but helps, it lags a lot during the process but seems to work, though I havnt tested it to be sure and have not updated again.
*My CH Pro pedals always worked with default profile even after update, very odd.

Please note: In my opionon this sim is still broken as it never did go back working out of the box like before, I simply dont use it enough to care but the default mapping aka “default profile” has stopped working and after deleting and manual remapping still does not work, which sucks…
And in game basic controls menu is completly blank, so theres that.
Peace Im outa here!

I am having the same problems. The new mandatory update has made my saitek panels and CH products useless. I’ve tried to everything from hotswapping the USB’s into different ports. Restarted my computer and the sim multiple times. Downloading drivers for the products with a computer restart. It is clear that the new update; although looks great, is trash. I will have to pull other peripherals out to see if they will work.

Same here: no brakes, ailerons, elevator, throttle, propeller, mixture… all no longer working.

If you can’t set them in a new profile it probably means a driver update from the manufacturers but first it’s probably worth checking in Windows settings if the buttons and axis’ are registering. All I know is thas my joystick was recognised as unknown in MSFS but I still got it to work eventually.

Hi new guys! I agree with ^ Snail 93

Options → Control options - > Sensitivity → move your controls
If these work DO NOT mess with Windows anything or drivers, your problem is inside the sim!!

Before you try everything I compiled, assuming you have a stock build, meaning you haven’t changed anything besides say graphic/user settings. Try deleting all the profiles for everything and making new ones.

Options → Control options - >
Click a device (yoke) - > Preset manager → trash can → yes → apply and save →
(move arrows under (yoke) and repeat delete all of the (profiles)

Click a device (yoke) - > Preset manager → + → (name ) ok → search by input (move control) → apply and save

Repeat times a million times, welcome to my life, default profiles no longer work after update i believe.
Peace and good luck !

Refer to earlier post for compiled list of other ideas after

1 Like