Update not detected

Update not detected when I open MSFS, manual check in store of Xbox App. Reinitiated Store and reinstalled xBox, no joy.

I’m experiencing the same issue. This is an on-going issue for me with updates. This is the most frustrating aspect of MSFS since its release. It is incredibly frustrating to spend hours troubleshooting update issues and have the “fix” change from update to update.

I don’t see update as well. Ridiculous.

Try go the the My Collection part of the XBox app, then Manage Installs…


The only options I can see in xbox are Play game or uninstall. Nothing else.

Stuck on 24GB download have uninstalled 3 times completely removed from my PC still will not go past 24 GB it has been 101/2 hours any ideas anyone

I followed the various troubleshooters on ZenDesk. What finally did it for me was to run the Windows Store Troubleshooter. When prompted, I reset Microsoft Flight Simulator through Settings > Apps & Features, searching for Microsoft Flight Simulator, clicking Advanced options and then clicking Reset. This seems like a fairly inelegant solution, but when I went back to Store, clicked Download and Updates > Get updates, started downloading. The initial download from the store was 500MB and 137GB once the system launched.

I have to do that every update. MS store and xbox stuff is broken since long time.

137 GB seems like the whole game reinstalled.

I have the same problem.

Well I am done had a gut full of this absolute rubbish 101/2 hours done everything in the book still no go
I will stick to P3Dv5.2

It worked now! was AFK for about an hour and when I came back I checked again and it offered me the update.

This helped me. Thanks for the info.

Maybe the same: I tried 3 times. At each time there are 16.61 Gib to download but the task bar is blocked with 1/21 and unzip of a fsbase is running since some hours !
Have you a solution ? I didn’t find it on the forum

I ended up having to reinstall windows a bit of a pain it had something to do with the server been down

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.