Update 8 not shown

Hello,

when I’m launching MSFS I don’t get any notification of the new Update as it says I have 122.2.
I have already tried wsreset.exe as well as opening the XBox launcher but no new update is shown.
Are there any further solutions? My Windows 10 is already up to date.

Thanks
Alex

Are you on MS Store or Steam?

I have the MS Store version

Temporary uninstall av software.
Restart PC.

Terminate → reset → repair microsoft store app.
Terminate → reset → repair gaming services app.
Terminate → reset → repair xbox app.

Restart PC.

Update system via windows update.
Restart PC.

Open microsoft store app - click library → get updates

If you haven’t tried this, it may help.
Go to the MS store, and select the library icon bottom left.
At the top of the page, select install updates.

Thanks I tried this but unfortunetaly without success. Guess I have to reinstall MSFS or wait if it might be an issue with Microsofts servers

Did you try logging out and back in?
Windows updates pending?
PC clock re-synced?

Thanks for your suggestion. Yes, I logged in and out for MSFS, Windows Store and XBox. There are no new updates for my windows system (also no optional updates).
I just resynced the clock and the seconds of time indeed changed.

Interestingly there appeared a cloud symbol cleared next to “Digital Ownsership” for MSFS, I clicked it and now it says “An error occurred on our site”, don’t know if it has something to do with it

Right now there is a major issue at the store.
See this article:

https://support.xbox.com/EN-Us/xbox-live-status

1 Like

Unfortunetaly it got worse. I tried to reinstall it. I removed it and now I can’t install it…

Did you try resetting Gaming Services from the Window’s Apps and Features menu?

Seems exactly same issue
You found a fix yet?

Did you try any of the suggestions in this thread?

Yes I did. I had to reinstall Gaming Services via the X-Box app instead of the Windows Store. This fixed it for me. I can now install MSFS, also I heard it helps when the Update doesn’t appear.

1 Like

Yes, but it didn’t help since I had to reinstall Gaming Services through the X-Box App instead of the Windows Store.
Thanks at everyone for the suggestions :slight_smile:

1 Like

Many thanks
resolved after many hours