Update broke my Bravo trim wheel

As the title states, my trim wheel has ZERO effect since the latest update. Whar are the odds they will ever create an update that leaves the rest of the sim unbroken. If anyone has a fix for this, please advise.


Topic moved into #self-service:peripherals and tagged #honeycomb

There is also a #bug-logged topic here:

My Bravo trim wheel works. I’m flying the G36.
What plane?

It didn’t, check your bindings.

Yes, it did. My bindings are the same as they were before the update.

Default C172, Savage Grravel, and Flying Iron P-38. It works on the Kodiak.
All I’ve tested, so far.

I just tried it in the default…Works like a top.

When you look at it does the animated wheel turn. If not then it’s not bound correctly. Joystick button 22 and 23.

It was already broken for me in the C152 in the previous update. Technically worked but you had to crank it like crazy to get even a little movement. I’m using Joystick Gremlin to map it to a vjoy and better control the behavior now anyway…

It turns minimally. Hard to see the motion but it’s there. Then, miraculously, it turns itself back almost as if AP is engaged but it is not. This is all post-update. It was working before that. Works fine in the Kodiak, though.

Let me know how that works for you. Thanks.

If it moves and then moves back something else is mapped to it.

Same happens to me. . .and not just the trim wheel, but the “selector” knob tied to “plus” and “minus.” They do not “spin” as in selecting an altitude and switching to 1000’s instead of 100’s when turning slowly. (Except for heading. . .but with the Working Title Garmin, only positive HDG increments work now. Doh!) See this other thrread for similar complaints.

I am out of time to try it out flying, but will check again tomorrow or possibly later tonight. It’s possible that the really (and I mean really slow) trim adjustments shown on the trim wheel animation are actually impacting trimmability in the air. I’ll check with the 172 and Baron and report in.

I checked all the mappings. finally logged out of FS and logged back in causing an immediate CTD. After restarting, I discovered that all my control settings had been reset to “Easy” but, miracle of miracles, I have my trim wheel function back!

My suggestion, to anyone experiencing a dysfunctional trim wheel is this: Log out, log in, go to controls and see if they’ve reset to 'easy." Go through your controls an set them all to “Default.” Yes, t was a pain to redo a bunch of settings but it was worth it to get the wheel functioning again.

Caution: While this worked for me, your mileage may vary. Attempt this option at your own risk.

Cheers! :sunglasses:

Excellent!! So glad you got it going. Sometimes you can delete the profile, save exit FS and then startup and readd the profile.

I wish we could save the profile away from the game.

1 Like