Update Freezes stuck on packages

Steam Edition
Windows 10

Hi, I don’t have room on my C drive so I’m trying to install on a different drive. The initial install goes fine but the 150 GB update gets stuck every time (usually on Asobo-landing challenge-scld-llanadagrande-01.6fspackage).

This appears to be a wide spread issue that I have so far failed to find a resolution for online. These are the things that I have tried.

  1. Limiting download speed to as low as 500kb/s
  2. Disabling IPV6 in network settings (per advice online)
  3. Disabled Window Auto-Tuning (per MS advice)
  4. Starting the game offline to change some settings.

Any advice would be greatly appreciated. Now that Siatek is supported I can’t wait to get flying I again.

Try disabling Antivirus and Firewall, just to see if it can get past that file point.

Thanks I tried this but same result. The app just keeps freezing.

Whenever I reinstall FS2020 and I get stuck with some specific package, this trick always helps:

  • Kill the stuck installer.
  • Go to the folder where you are installing the sim and look for the partially downloaded file(s) that is stopping progress (same name as shown in the installer/updater).
  • Delete the file(s).
  • Restart the updater/installer.
1 Like

Hi Eric, Thanks for the advice. I’ve been trying this method for two days (probably restarted the installer a couple of hundred times lol). Its slowly progressing but I feel like a madman keeping at it for this long. This is clearly a widespread problem and I’m starting to resent MS for not addressing it.

Yeah, the installer has been broken ever since the sim launched. It’s a shame and something unexplainable to me to this day. The few times that I’ve had a file getting the installer stuck, that trick helps it continue but if it’s happening with every.single.file for you, then clearly you should try something else. Maybe try installing the sim from scratch on a different hard drive if you have one?