Update Patch is not in my Microsoft store

I would like to know how many peaple are missing this latest update
I have never had any problems before with updates but this one just doesn’t show up.

1 Like

Did you check this page?
How to maintain and update Microsoft Flight Simulator? – Microsoft Flight Simulator Support (zendesk.com)

Hi, You can try the force update, by opening ms store and open the flight simulator page from it. The download will start shortely

Thanks for the reply. Yes I have but to no avail. If this is not a common issue I shall need to dig deeper

could have been updated without you knowing? also depends on servers and location perhaps

It sounds like I have a windows update issue I have launched it from the store but I still have version .

Same problem here. No update.
I’m playing the old version without problems so I’ll wait for a miracle. :smiley:

I have the same problem and i can not even play the older version. I see the update ready in windows store but when i click on it to download nothing is happening

I didn’t get it till this morning, I was using it till 1am EDT (USA) last night. Maybe they cycle updates across servers at different times? Apparently some people got it yesterday?


really strange. Everytime I did updates with simply start MSFS with Icon, nothing else. After sim goes to state of checking for Updates, all is ok and Update is discovered with redirection to MS Store. Here carefully, you need also click Update right Icon (refresh) because to also me nothing started. Only after click that refresh all started automatically.

I had get to click the “Get Updates” button some 10 times before the update came.

I’m having the same issue. When I launch the game it tells me there’s a mandatory update. I hit ok and it takes me to the MS store on the MSFS page but my only option here is to click play. Previously it would show update and I would be on my merry way. I’ve clicked downloads and updates in MS store and it shows everything is up to date. Also checked windows updates and everything is up to date.

I’m hesitant to delete and reinstall the game so hoping someone might have a suggestion. If I do reinstall does it keep my profile intact or would I lose all of my hours and accomplishments?

Yes, I’ve had that happen. In that situation, I either wait, sometimes it takes a minute or two to recognize, I go to, instead of the game page, the updates page and pick on the MSFS icon there to take me to the page, or, worst case, log out and log back in again. But, yes, sometimes it takes a few times for Store to recognize it needs to do the update.

Solved… Hurah
I had an xbox update with an error code of 0x800706D9 . The Storage Service in services was disabled . setting this to automatic got me going

I just opened MSFS and had no update whatsoever… this is getting out of control :unamused:

Hi! You need to check the client (MS Store or Steam). Per the patch notes, there was no in-game update.

Check the top window bar in MSFS for version displayed to see if the client had already downloaded in the background.

If the version isn’t and there’s no download from the client, try re-starting your PC and check the client again.

1 Like

Does someone have a solution?

thanks Hester! you were Right, this was a silent update for me, it happened in the background… problem solved :+1:t2:


See if there’s any pending Windows 10 updates as that at times will stop the Store from updating.

It’s not a Windows 10 issue. There seems to be an issue with XBOX services again if you look at their status page. Statuses have changed from down to online multiple times in the last few minutes.