Updated and YET AGAIN "This app can't be opened"... What is the fix?

I found a fix last time and thought I’d remember it and I’ve tried everything and nothing is working. Tried uninstalling and reinstalling XBOX app, Gaming Services, nothing works.

Why do we have to go through this every update???

Can someone remind me what the fix is?

Reset MS Store?
Were you using Google map replacement mod?
How far do you get when things don’t work?

I did that too. I reset the Store, Repaired the Store, did the same for gaming servcies and xbox app. Nothing is working. I uninstalled and reinstalled the Digital Ownership as well. Nothing will open this ■■■■ thing. I am NOT going to do a 3rd reinstall of MSFS…

Do you get to the Store?

Yes of course I do.

I just noticed that right before the App can’t open window there is a quick flash of another window. It’s so fast so I can’t make out exactly what it says but the window title appears to say, “Can’t open dependencies” or something like that. How the hell do I satisfy all dependencies? And why do some of us have this on PC EVERY SINGLE update???

I think I’m starting to remember now. I think last time the solution was to reinstall Visual C++ or something?.. gotta remember. Gonna try that now.


Well, I uninstalled and reinstalled the latest version of visual c++, only 64bit version, but still didn’t resolve the issue. I had to go out, couldn’t spend more time trying to fix this so I’ll have to try doing all packages and also 32bit versions either later tonight or tomorrow. Either way, the end user should not have to do this or anything like this after every single update.

Disable your antivirus during installs.

While my symptoms were not a 100% match to what OP describes, I think it has value in this thread. I too was facing issues just about every time there was a windows update, or an update to the xbox app, or gaming services, etc.

While the error message wasn’t the same, the gist of the problem is that xbox app couldn’t open the sim… or any other games (except MS solitaire).

The specific issue I was seeing, was that the XBox app didn’t detect the game installations as good, and marked them with an exclamation point. And if you tried to open said game it would just bounce you to the Gaming Services page in the MS Store.

Yes, I went through the several ways an issue of this nature is often fixed, and while that would get me to a working state, the next time there is a windows update, or an update to gaming services, etc. the problem would come back.

Or, if I tried to run the xbox app “too soon” after a reboot, it would also trigger this problem state. Huh? What’s “too soon?” Yeah, I know. But I found that if I waited about 15 minutes after rebooting to launch the XBox app, it wouldn’t trigger the problem.

Keep in mind, no problems in any other way shape or form. Ubisoft games… fine… Steam games… fine. Anything through XBox App (Gamepass PC)… not fine. It almost drove me to just cancel the service.

What I finally did to fix it – knock on wood - was I totally rebuilt my user profile in Windows 10. Which basically means I created an admin account, then used that to backup my user files and %APPDATA% stuff, then deleted that account and created a new one, and copied the user files and %APPDATA% stuff to that new account, gave that new account ownership, etc. and then changed that local account to be associated with the microsoft account.

After having done that , so far I have no issues. And since I kept the user files and %APPDATA% stuff, it saved me from having to re-setup everything that is not Microsoft, which would have really sucked.
I am convinced that something hosed the windows profile. Perhaps, and I am just thinking out loud here… LOL… it was that I had opted in to the Insider program and activated the Xbox Gaming preview?

Yeah, it was after that when the problem went from being something that happened once in a blue moon, to becoming a daily issue.

And no, leaving that insider preview did not fix anything. Probably the last time I will Insider preview anything having to do with Xbox App or Gaming Services.


No idea why your post was flagged let alone hidden by the mods, but anyway, No such issues on Steam. It’s because of your issues and hundreds of others why I ignored the MS Store release, it’s a mess of a system whereas Steam has been rock solid for years.


I’m not a mod, but I would suspect probably because it violated the Code of Conduct, in particular:

:small_blue_diamond: Obscene / Vulgar or Inappropriate Language and/or Images

Posts are hidden or removed if they violate the Code of Conduct.

Also from the Code of Conduct:

:small_blue_diamond: Discussing Moderator Actions

The Microsoft Flight Simulator forums is not the place to discuss disciplinary or moderator actions taken on an account, including your own. Please DM the moderators if you wish to discuss actions.

So the reinstall was at about 35% downloaded then bam, the window just closed. Tried to open MSFS and back to getting The App Can’t Be Opened. Just wow…

Man, you sure are having troubles with this.
Here is a link that may suggest a few things to try.

1 Like

Thanks man, but I’m trying the install one more time. If it fails I’m just gonna take the loss and rebuy it on Steam. I just hope I can copy my settings & hardware profiles from the existing MSFS folder in my profile directory over to the Steam location. I’m sure they’re the same files so I think I could figure it out. I will have to resetup all my default camera positions for every plane which is a major PITA but oh well.

really? isnt that obvious???

Have you been having these issues for a while?
If so, hold off on steam.
If the issues are with your windows program, steam will be no better.

I think at this point you should do a Window’s reset, as painful as that may be.
I would uninstall the sim, delete all the remaining folders and then reset Windows.
Get all the Window’s updates completed and then try installing the MS Store version of the sim.

I didn’t see it the first read through :wink:

1 Like

I have this issue every update since I think SU5, never an issue prior. I’m definitely not reinstalling windows, not for msfs lol no way. Only other games I have on my Flight Sim machine are X-Plane 11 and Eurotruck Simulator 2. Both work flawlessly and both update flawlessly.

Microsoft should’ve never implented this stupid Store and Xbox nonsense. Go to the store and all it does is open the Xbox app :rofl: There are way too many dependencies such as the two just mentioned then there’s Gaming Services. Overcomplicating things leads to a lot opportunities for problems to encounter.


Got the sim reinstalled after a few hours of downloading everything and installing all the world updates and getting everything as it was and such. I did a few quick landing challenges and a test flight and on a positive note I will give them this… holy geez what an improvement!!! Stutters are gone, at least so far in this brief testing. I haven’t seen the sim run this smooth since SU4 and prior. It’s like a whole different sim performance-wise and all my settings are the same. I couldn’t believe it. I didn’t even bother to check frame rates cause as it was I couldn’t care it was so smooth.

So, at least there’s that silver lining… until next update :roll_eyes: Hopefully won’t have a problem next update. I fully removed my AVG antivirus even though I’m not sure it had anything to do with anything. I use only the free version and have MSFS in the excluded list and even had it turned off but after that download window just disappeared I wondered if maybe it’s still interfering in some way. I checked its logs and nothing there but we’ll see.

1 Like