Updated from store now will not launch

Just done the 600mb update from windows store. Now when I try to launch flight sim nothing happens

It can take a bit to start else a reboot might work.

1 Like

It has been 20 minutes and still nothing. Tried a reboot and still nothing. Nothing flight sim related is showing as running in task manager

Are you launching from the Store or through the FS Program?

600MB update? I just did the update and it was 8.79GB. It loads fine for me, even though the very first time I was staring at a black screen for quite awhile and it made me a bit nervous. Are you sure you updated?

Tried launching in the store and fs program. The 600mb update was the one in windows store. I have not been able to get into flight sim to do the main update

It is about 600Mb update from the Store, and then 8Gb in game.

The installer is 600MB, gotcha.

1 Like

Had to unistall and download the whole 95gb again but all working now

I have the same issue.

Anyone solve this ?

I had to uninstall flight sim and download it all again from fresh