V-Sync in PC mode affecting VR and causing FPS impact

Please only post bugs that are new in this build, and tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Haven’t seen this logged yet, so wanted to create a topic for it.

As discovered by @Mayhem6633 in a different thread - If V-Sync is enabled in PC mode it will impact VR FPS.

Thought about your thread when I started flying in VR earlier and I had low FPS (lower than usual)… tried turning off V-sync in my PC mode options, everything became super smooth as it usually is.

Then I was wondering what would happen if I turned V-sync back on in the options (during the same flight) while still in VR… my FPS didn’t drop and everything remained smooth…weird! Anyway, there is definitely something going on!

1 Like

I had a similar problem, fps in VR was limited to 60 (monitor refresh rate). Enabling disabling vsync in the simulator did not help. The installation of vsync = fast in nvidia settings helped. Now if possible, I am limited to the Oculus Quest 2 frequency (72fps)

1 Like

That’s because you’re already in VR, if you exit VR and go back in chances are the FPS drop would come back. Think of starting VR like you’re restarting the Sim to force graphics changes take effect, like you have to restart the whole Sim for some graphical options.

Yeah that would make sense! These stutters are not something that appears often on my machine, but next time they do I will make sure I test turning VR off and back on after turning V-Sync back on to see what it does.

I just noticed when ending a flight and coming out of VR, the PC setting for vsync is turned off. Not sure if it is turning off when entering VR but I think it should remain at the setting you had. Not sure if it is affecting VR or not

Just Googled and found this topic, G2 headset, 12900 & Rtx 3080ti. I’m getting around 36 fps over London with live players and weather, Gpu at 99 - 100%. If I turn on Vsync in PC settings and set to 60 nothing really changes as far as I can tell, if I set to Vsync 30 my VR fps drops to 30 - 31 and Gpu drops to 84% ‘ish…… any observations?

Fixed as of Sim Update 9.