VCRUNTIME140.dll Error

I had FS on an older computer. While it ran poorly, it did not ctd (not that I can remember). My new computer is having problems with the VCRuntime140.dll error. This occurs after about 15-30 minutes in the game, every time.

I may have narrowed my (and maybe others’) problem down. My new computer is running a few applications all of the time that the old computer was not. I started by disabling these programs. I have now narrowed it down to one of two programs:

Corsair iCue, or
Logitech G Hub

With both of those programs disabled I just did flights for 3 straight hours - impossible before. I’ll enable them one at a time either tonight or tomorrow and see what happens.

I also note that I am running an AMD 5600xt. I ran with just the driver (uninstalled Adrenaline software) and this did not fix the problem. I have yet to reinstall Adrenaline. If I can get the program causing the CTD nailed down, then next I will reintroduce Adrenaline and see how it goes.

Good luck to all.

Edit: Logitech G Hub did NOT crash the sim

Edit 2: Corsair iCue - CTD

looks like you found the source of your problems then.

Hello everyone, I return to this thread since yesterday I inexplicably had 140.dll-0000000005 again, without having modified anything in FS or the Nvidia control panel. Well, looking at many posts from colleagues, I observe that when you review the events you only see those produced in “Application” but yesterday I realized that in the “system” events there are also errors and the most worrying thing is that in my case they are the ones that They produce the errors in the Application, since they occur a few seconds before. In my case it refers to “nvlddmkm.sys”, I don’t know if this is the case or in other cases other drivers are involved. This kernel is part of the Nvidia driver set in this case. So I wonder, are we not targeting the Application error, when the real culprit is a driver? I say this because I have not seen in the forums anything related to this.
I understand that if an error occurs in a driver that conflicts with something in the simulator, automatic and cascading, other errors occur in the FS application.
Sadly I am not a computer technician how can I find out more about this file. Looking in St.Google and in not very old publications there is something that does not match my configuration, almost all the solutions refer to the location of said file that they follow is in this path C: / Windows / System32 / Drivers, but not I managed to see it there, looking for it on my PC I found it in this path C: / Windows / System32 / Drivers Store / File Repository. Having seen this, I reinstalled the Nvidia drivers again in case there had previously been a bad installation or a corruption in my drivers and the new installation ignored that file again in the path indicated on the internet. I would like if you. you can look at this.

  1. If you get an error of 140.dll or 000000005 not only look in the event viewer in application but also in System.
  2. If the file I refer to, where do you have it located?
    I have installed the 461.40 drivers, I will continue investigating on the internet.
    Thanks

If installing older VC++ redistributables, you should uninstall the later ones first, and then re-install them again afterwards (and use the combined 2015-2019 VC++ redistribs) as they need to be installed in-order.

That’s interesting. I’ve just rebuilt my PC. Didn’t reinstall the the G Hub yet but did install iCUE. Still getting CTD. I’ll try disabling iCUE next.

Hi fellow simmers. I had been struggling with the VCRUNTIME.DLL CTDs for a while. Finally did some digging and found that there were several installations of Microsoft Visual C++ XXXX-XXX Redistributable (x64) packages installed on my system. Like 8 or 9. I finally ended up deleting all of them and reinstalling the latest from the x64 link here https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0.

I have now about 20 hours of flying since the changes and no CTDs so far.

Remember that some of the programs you install will also “optionally” try to install a specific VB version because that is what they used to compile the program in. So, you end up with a ton of different versions of VB installed. I know that some of the 3rd party flight sim companion apps that I have installed do this. So, going forward, I will make sure that there is only the latest installed. If the 3rd party app stops working, then so be it. I would rather fly than troubleshoot other programmers’ problems.

Hope this helps!

Nope, never a good idea to uninstall older versions. That is asking for trouble from Windows

1 Like

Anybody still having this problem… Recently started having CTD with VCRUNTIME.DLL started having shortly after RX6800xt upgrade running with i7 7770k 32gb Ram and SSD

2 Likes

Yup, I have RX6800XT and am getting VRRUNTIME140.DLL or D3D11.DLL crash every flight. Running 10850K with 64GB RAM. It happens mostly in VR mode. Lowering the render scale in sim has helped but not a real fix. I think the SIM has a bug in utilizing GPU at max load. I run a waterloop and the hotspot on my 6800XT never rises above 72c. And it happens only with MSFS2020. I hope this will be fixed in the next sim update. This issues has been around since the release, though.

3 Likes

Yeah, definitely something wrong… I’ve spent the day trying to sort it I was finding if I take off from Southampton flying to France it was crashing in the same spot every time… I did the flight 3 times and everytime it crashed, I’d also find it was crashing on flights to airports I hadn’t visited before… So I deleted the cache turned on DATA Limit and done the flight again and this time no crash and I managed to land at the airport… so I’m not sure if this has fixed my problem but gonna try a few new routes and see what happens

1 Like

I’ve open two tickets thus far on this, first ticket came back with the “delete the c++ redistributables and reinstall.” I did and CTD continued to happen no matter where I was flying. Put in second ticket response was “send us your msinfo and dxdiag files” did that and… Nothing back.

I’ve only started having this particular CTD after the UK update. There’s so many “try this, do that” things out there that with so many variables being changed we’ll never know what is truly causing all of these issues. But I get the VCRUNTIME and now .NET errors.

1 Like

Yeah I had another crash… after deleting cache but then realised i turned back on the Text to speech so set that to Windows offline mode and has been ok, but yeah lots of people having this problem in different scenarios, I think it was probably after the UK update I started having trouble, Hopefully, they sort it soon

1 Like

So after you said that Azure was turned back on by the latest update I went and checked and sure enough it did turn Azure back on after I had turned it off back a couple months earlier. Here’s what I did:

  1. Deleted cache AND set the new cache to be saved on my F: drive (which is an SSD and where I have the Steam version of MSFS installed - I don’t know if that makes a difference)
  2. Set “Text-to-speech” to windows offline
  3. Downloaded the “hotfix” yesterday (I know it’s the “flaps” fix but almost a gb to fix a config file? This is suspect)

I changed 3 variables. Afterwards I flew in multiplayer on East Coast server, N. Europe server, used 3rd party aircraft, default aircraft, various weather setting, all for about 5 hours and not a single CTD.

My money is on Azure causing the runtime error. Maybe the cache being what it is but I don’t think so. The “hotfix” maybe if they put something in there they didn’t mention…

2 Likes

Happy I found this thread and the suggestion to change the Text-To-Speech option.

Since I don’t care about any of the built-in voices in MSFS, I set it to OFF. Hoping that might address the issue I’ve been having lately with random CTDs caused by VCRUNTIME140.dll.

1 Like

Ever since I installed my new Gigabyte 6800XT yesterday (running the latest 21.2.3 drivers), I’ve been consistently getting CTDs literally every single time, ranging from anywhere between loading screens, main menu and the first 5-10 minutes of each flight, usually when switching between apps. As for the errors they are not always the same, but I’d never seen a vcruntime140.dll one. I must have counted more than 30 CTDs in a row.

I hadn’t got error vcruntime140.dll though until today’s new patch and now I get only this one even without switching other apps. Also no other errors, just vcruntime140.dll.

I found that the only way to stop this is to launch AMD Radeon settings, go to Performance → Tuning tab and set Tuning Control to Manual. I don’t have to enable any settings in particular, I just leave them as they are, ie. all disabled. And I haven’t got a CTD in at least 10-20 tries with more than a couple of hours of total flying time. It can’t be a coincidence. This worked both with the previous errors and also with vcruntime140.dll.

It’s as if when Radeon uses the default settings to automatically overclock the GPU, the game always crashes at some point. I’ve been running Division 2 at ultra settings and I’m not getting any issues, so must be an MSFS thing. Guess I’ll just stick to manual settings until further notice, as they don’t seem to impact performance anyway.

I’ve been using manual overclocking with rock solid stability. Only MSFS crashes the sim. I was able to minimize CTDs by upping the power limit and lowering the graphics settings, but after the SIM update, it still crashes with the same vcruntime140.dll or d3dll.dll. So frustrating. I hope either AMD or MSFS will fix this soon, but they both have been silent. Keep sending your bug reports so that the issue will get some attention.

1 Like

It has been proven (anecdotally) that overclocking is the single greatest cause of CTD. Many users are unaware that most motherboard and memory manufacturers have some overclocking ‘built in’ to the default settings. A quick look at the BIOS to confirm that no BIOS based overclock is enabled, followed by checking any ‘boost’ software that is loaded by the MB/Mem manufacturer at boot time.

I have seen numerous cases where an overclocked (memory boosts count) passes all the tests you can throw at it but still crashes under MSFS.

My suggestion would be to disable ANY O/C and test MSFS. If the CTD’s persist then confirm NO boost is applied to MEM/CPU/GPU. If they still persist then you have a separate issue. (less than 32GB total available mem is a good bet)

If the CTD’s go away, you can start playing with your O/C settings and test each change, in MSFS. I have some clocking on my system and have not encountered a CTD since August. Obviously it is the balance between CPU/GPU/Mem/pipeline that is critical.

Start at 0 at work up. Easiest way to narrow it down.

1 Like

I have. I’ve spent the last 8 weeks trying undervolt, underclock, stock, power limit, RAM timing, anything you can think of. This particular CTD happens in VR mode only. It is how MSFS and the GPU drivers interacts. Trust me, it’s not the overclocking that is causing this CTD.

May I suggest then that you take advantage of the VR bug sub. This error, affecting the BASE sim is a very different animal from your issue. There may be some VR users that can assist you to find a solution.

1 Like

That’s a good approach and advice there, thanks.

MSI B550 motherboard has been running under Game Boost mode with default settings for months now with no issues really, boosting a 5600X and also an R9 290X (slightly and manually O/C’ed via Radeon app). Also 32GB RAM is running as XMP2.0 at 3600MHz. So CTDs can’t be coming from there.

The generic CTD issues began immediately after I upgraded to a 6800XT (and only under Automatic OC mode as it seems) while the VCRUNTIME140.dll-specific CTDs began after yesterday’s patch. I assume that Manual mode in Radeon app won’t O/C anything unless you explicitly tell it to. So for now it seems that “no GPU O/C = no CTD”, at least for me. I’ll keep testing.