Vertical squares in scenery airports and autogen





squares populating hills during approach

The Scourge of the black vertical squares! Please…please help.

System: i5-11600KF @ 4.5ghz 23% load during flight
RTX 3060 12gb
32gb DDR4 Ram.
Samsung 2TB SSD (dedicated for Sim)
32" LG G-syc monitor resolution @ 2560 x 1440 (tried lower res - no diff)
DX11 (tried DX 12Beta - no difference)
MSFS 2020 Premium Deluxe SU11
latest NVIDIA driver 526.85

NB the subject squares are indicated in the images in the horizon areas , not the large black square on apron which is part of the scenery

I have been plagued with these squares for the last several months, I think
they may have started around SU9, sometimes I can get them to disappear if
I delete the NVIDIA cache files before running, but lately this has not worked.
I have a constant 40-50mb sec wifi internet connection

Sometimes, if I turn off Bing maps and photogrammetry in the Data settings whilst parked at a gate or the
the apron they go but eventually return. I have tried all manner of graphic settings from low end to high end. I have also have rolling cache enabled.

While flying, the squares disappear at about 1500-2000 feet, allowing a normal cruise to FL410,
they reappear during descent, again at about 1500 feet.

They are not discriminatory in that they appear at 3rd party or default airports, in built up or
sparse areas. Sometimes they are solid black or a pixelated grey in color.

In summary, apart from this issue, the graphics and visuals in the Sim are superb and realistic. I do not have any lag,stutters or low frame rates.

Having exhausted all options and wasting far too much time trying to fix this I am open
to all suggestions that are offered.

Steve

Have you deleted the rolling cache?
If you have any mods, have you tried with the Community Folder empty?

It seems like it could be a possible corrupt texture or file related to trees or autogen. Do you have any add-ons installed like Bijan’s Seasons or REX AccuSeason?

I had already deleted the rolling cache previously and I don’t have the “Seasons or AccuSeason” installed.

My latest attempt to fix this was to completely delete my Nvidia drivers using the Guru3D tool. I then reinstalled the current 526.86. The image below shows that this didn’t work either.

Yeah, just from quickly glancing at your screenshots, I’m thinking this may not be a driver issue. The rest of your images look rendered correctly. I’m thinking this is more an issue with your FS installation, possibly with textures or LOD. Have you tried reinstalling the sim?

Yeah, I’ve thought about reinstalling…as a last resort - it’s a 2 year old installation with all the SU and hotfixes added so its bound to have conflicts. the problem is, to do this, is going to take a long time to download.

On a positive side, I’ve been playing around with the photogrammetry settings and found that with it OFF, the squares mostly disappear with little effect on the visuals. I’ll give it a few more days, if no go, looks like a reinstall is inevitable.

The Problem has been solved!

After 2 weeks of this ongoing problem and last resort before a complete reinstall was to empty the files in my Community Folder and put them put them back one by one - there were quite a few but the Addons Linker Utility made it a lot easier.

The problem file was - “Trees Draw Distance Fix v1.7.4”. I installed this in the early days of the MSFS 2020 release and overtime, was overlooked and just remained in my Community Folder.

After isolating this file I now have a truly different looking Sim…the graphics and visuals are so realistic, words cannot express.

I’m now a happy Chappy!