VFR Flight Plans Broken Again?

Maybe I was mistaken, but before SU8 I thought the VFR Flight Plan Bug had been fixed. There was no announcement, but for a while, a month or so, I was able to load a LNM VFR Flight Plan and it worked with the Autopilot (When engaged, the airplane seeks and tracks the flight plan). Now after SU8 the same problem that occurred after SU5 is back i.e. when loading a VFR Flight Plan, the airplane will not engage or follow the Autopilot. After SU5 a workaround was found (Loading the Flight Plan as IFR and cancelling IFR after takeoff). That workaround works again. Why can’t we get this fixed? It’s been 7 Months and 3 Sim Updates and we stall cannot load a VFR Flight Plan that will work with Autopilot. This worked perfectly before SU5. I am flying the C-172 Classic for reference.

If you are using G1000 NXi, remember you will need to get within 30 degrees and two dots of the Magenta line before GPS kicks in. It’s not like the old G1000 where switching to FMS automatically gets you guiding on the path.

I think OP is using GNS530. I’m not sure how that handles proximity.

I recall having some difficulty with that system but it was before I learned about arming the GPS till it locks on with the NXi.

No using the C-172 Classic (Steam Gauges)

Do you have the GNS530 improvement mod?

No Mods Installed

I just did a quick VFR hop in the 172 and didn’t have any issues with the AP not engaging/following correctly. I don’t have any mods either, and just did a standard VFR flight plan on the world map (no “IFR flight plan” workaround.
If you have a specific flight plan/airports that you had the issues with, I can try those and see if it’s somehow related to a specific area/airport.

I will try that tomorrow. I was using a flight plan set up in Little Nav Map.

1 Like

Well I had an opportunity to run some tests last night. Yesterday a response Habu2u2 indicated that he created a flight plan in the MSFS Flight Planner and did not have any problems. 2 other earlier responses asked me if I was using any mods and I respond no. At the time I was thinking of Autopilot Mods. Correction: I am running 2 Mods. MSFMobileCompanion app and LittleNavMap. Those responses got me to think that maybe my problem was with Flight Planning or Plans. I should point out here that I always take any Flight Plans I have downloaded and put them into LittleNavMap so I can see route things Flight Altitudes, Adjust Flight Plan Altitude and waypoints if necessary and other things. I then save the plan as MSFS2020PLN to a folder on my computer for ease of finding them or making future adjustments if wanted. Anyway I ran several tests. All were using VFR Flight Plans and then connecting GPS & Autopilot in the airplane to see if they captured the flight plan correctly:

  1. I ran 2 Flight Plans that had worked before SU8 (Both 3rd Party Plans) –They worked. I do remember that I had to make some adjustments to the waypoints because of modifications to the plan, i.e. shortening the route, the waypoints did not run consecutively .i,.e. 1,2,3,etc. Prior to that modification I was getting the same autopilot GPS problem. “Short Memory”
  2. I created a Flight Plan in the MSFS Flight Planner – It worked
  3. I loaded the 3rd Flight Plan I was having trouble with directly into the MSFS Flight Planner from the download– It Worked
  4. I created a new Flight Plan In LittleNavMap – It worked
  5. I reloaded the LittleNavMap plan I was having trouble with. Same Plan as #3 – It Did Not Work. I should say it did not work as the others who turned directly to magenta Flight Path when the Autopilot/GPS were engaged. I had the airplane pointed to the Magenta Line when I engaged the autopilot and GPS, instead the airplane circled back and around the airport and flew about 3 to 4 miles North of the airport to appoint that was not on the VFR map or in the Nav Log or Flight Plan. It then turned South onto a path that pointed directly to the 1st waypoint about 8 miles South of the airport. When it reached the waypoint it engaged the Magenta line and turned on course. Can’t Explain Why?
    When looking deeper I saw that unlike the other flight plans, this one was for a 3rd Party Mission Pack “Alaska Glacier Series”. I can only conclude that there is a mission point that LittleNavMap didn’t pick up and enter. Same thing on the other Flight Plan that didn’t work. On the LittleNavMap plan the airplane will eventually pick up the flight path, but in a roundabout way.

I appears that the VRF Flight Plan was fixed in MSFS sometime back before SU8, but not announced. Anyway that was made that’s good news…
Lessons learned:
When changing a Downloaded or Modified Flight Plan make sure the waypoints are in proper order i.e. 1,2,3,etc.
If using a “Mission” Flight Plan, probably best to load it directly into the MSFS Flight Planner instead of using LittleNavMap
Sorry for the long winded explanation, but I couldn’t thk of another way of explaining it.

1 Like

That’s some fine research work!!
I’m sure folks will benefit from your detailed explanation, and hopefully helps some other folks resolve their issues.

Thanks, I hope it helps someone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.