Violent autopilot induced aerobatics. So frustrating [SOLVED]

Yes, I make sure its trimmed. In fact I can get it to fly straight and level pretty well just by using quick jabs of the the trim buttons on the joystick. I then check by going hands off momentarily and only once its stable do I hit the AP engage. However once I do that BAM the trim wheel goes max nose down.

Im trying to figure out why the action is so extreme. What is happening to cause the wing to drop in excess of 90 deg, the trim to go max nose down just because I turned on the AP? Im checking stick settings and such! I will do a test flight without the stick maybe.

Yeah sure controls could have something to do with it. I fly only keyboard, it feels like the AP keeps the key pressed somehow. See my video.

But anyway I talk too much… :cat: the others are the experts here… I just met a system I didn’t know how to shut off… and it went unstable as soon as I pressed Cursor Left one time. I’ve some experience with software simulations, I think it’s overcompensating, but I did not write the MSFS kernel… and I did not follow procedure. If I would (see willisxdc) it probably would be be safe ? Just press the right buttons on that device, and don’t press any keys…

If willisxdc is right, it will only work when you activate it on course, flying horizontal with a reasonable airspeed. And apparently… hands off. No automatic manual override, you HAVE to press that red button on the yoke to switch it off.

Very interesitng, thank you. I will be spending the night doing more testing. Will try the other GA planes as well!

Those are good points. The problem is this does not happen in FSX or X-Plane 11 (identical GPS units).

This is the first time I’ve seen this sort of behavior. Even if the course is +90 deg off heading the system shouldn’t make the plane stand on a wing and become a lawn dart :frowning_face:

1 Like

A similar problem happened six months or more ago. Next problem is finding the link.

There was a patch done to the basic autopilot system.

I have only done maybe two flights since the patch, and have not noticed an autopilot issue, but I was not using the C172 either.

1 Like

I am using Working Title G1000 current release version.
Observed no adverse behavior in the C172.

1 Like

I have not tried the G1000 C172 yet, good idea I will test that also. Is that mod working well on the latest update? I have heard you can disable the synthetic vision using it which is also something I want to do!

I’m suspicious of this “alert” light on the autopilot panel? I haven’t looked up the documentation, but it goes away after takeoff for me and my autopilot works fine.

alert

(Shot in the dark – does calibrating the gyro help? ‘d’ on keyboard.)

1 Like

I will look into that thanks. But it should not cause that violent roll. My guess is that “Alert” is because the plane has 500ft to go to the selected alt. If I recall the first alert is given 1000ft before but I will check!

Thanks for the great tip about gyro calibration! I didnt know that ! Will try that too!

2 Likes

Now the same thing is happening in the cub (50 sec video):sleepy:

Just yesterday everything was fine. I flew for hours on autopilot. I’ve spent all day on this without success. I’m out of ideas. Reinstalling is out of the question, I’ve had to do it twice (the second time cos I got a new drive) and we cant keep reinstalling each time we hit a problem like this.

I’ll do some more reading. Thanks for everyone’s replies! I have noted all of them!

2 Likes

Have you tried flying without joystick, just to check about a possible hardware problem?

I have made a note of this and will try it first thing when I wake up! Thanks for the reminder, will let you know how it went!

1 Like

Saying an Autopilot does nothing automatically is like saying Garmin’s Autoland does not do anything automatically when, in fact, it does a whole lot Automatically at the push of ONE Button. Putting in the correct ILS frequency, positioning the aircraft correctly and pushing the Appr button on a simple autopilot will “automatically” turn the plane towards the selected runway once the autopilot “senses” the instrument landing system signal and the autopilot determines it is of good enough quality to follow.

1 Like

Great point.

That Autoland is truly mind blowing. Its only a matter of time before that reaches the next level - where you can hop into a light piston GA plane and say “Take me to [insert airport name here]” then sit back and fire up Netflix on a tablet.

Wether we like it or not - its coming.

1 Like

:grin: and they accused me of wanting to change MSFS into a flying camera lol. These tools just change flying to programming buttons and waiting for hours ! I prefer to fly my MSFS cameras manually :innocent:

@KatanaDV20 @ArcanePython931 @MeridianOwl4306
I refer you to this…

We have the picture and have a few under our belts too. That is why I ended my career as an old pilot not a bold pilot.

1 Like

:grinning: Solution found :grinning:

Hey everyone. I found the solution thanks to a user on another forum who told me to check my keyboard hotkey mapping. I want to share the solution so it will help a future n00b who might come across this thread.

I use the number pad to set cockpit camera hotkeys. So for example: NUM7=look foward left, NUM4=left wing etc.

  • So when I press NUM4 I see the left wing.
  • What I did not know was that NUM4 was ALSO set by the game to full LEFT aileron.
  • Another example. NUM2=look down so when I pressed that I not only looked down but was unknowingly commanding full UP elevator.

These big control surface deflections were confusing and over powering the autopilot.

I deleted all the hotkeys that controlled primary flight surfaces. Now I can use numberpad for views and the autopilot works without any issue!

Hope this helps someone. Thank you all very much for your replies :smiley:

9 Likes

Congrats @KatanaDV20 so we DID have similar issues after all… you were playing with keyboard and trying manual override of the autopilot without knowing it ! next move MS/Asobo, to take care of manual override. These keys should simply be disabled (like your stick is) while autopilot is on, or autopilot should react correctly when aeleron or elevator keys are pressed… l will put a wish for that… don’t expect many votes… keyboard players are a minority.

1 Like