VR and saving flight plan

Noticed that when you try to save a flight plan when in VR mode the sim locks up.
In order to get out of it, you have to close the documents file behind the msfs window, that was intended to save the flight plan.
The way around this is to do all your flight planning saving/loading before going into VR mode.

Ya, same here…
I just tell it to cancel saving or loading in VR.

If you use the in game FMS to plan flight, and not the world menu (like real life)
Then toggling VR mode deletes your flight plan.

:man_facepalming:

1 Like

same here, saving in vr mode sucks… All gets stuck I dont save anymore…

The last update claimed to have fixed this but it is still happening…

Loading a saved flight sucks too, because my flightplans are always gone! Makes saving even more pointless…

1 Like

It looks like the sim locks up, but actually the save dialog is accessible in Windows (as a 2D dialog), and you have to switch to it, which can be tricky.

Thanks for the suggestion.

stuff like this is where we see they took old code and didnt implement it properly. A sim lives on stuff like flight plans and saving the excursion and such. I thought I would try saving today after idk at least 18 months since i tried last. Thought it might be worked out…Nope. And I cant get to the save window when in VR as fullscreen just dont let it gain focus for some reason. So yea, only save in 2D, but stuff like this is where they need to just tighten everything up. But theyre in too deep now, and I’d probably mean tearing down all sorts of other stuff.

Same here - also one of the things that completely ruins VR despite how beautiful the game looks.

It would also be nice to have a virtual keyboard in VR to look for an ICAO in the world map.

Yes, that is a horrible UI bug, because it’s impossible to select the window to even cancel. Also using the mouse in VR can lead to disaster. I was thinking that “clicking in the right spot can cause a CTD” if it’s in the upper right-hand corner of the window…where the close button is! Pretty sure those aren’t CTDs but me actually clicking on one thing in VR, and another on the desktop.

1 Like

It is sad we are forced to use mouse in VR in the first place.

Hear hear, my interaction is a combination of mouse (which is OK near the bottom of the screen, but no bueno if you’re clicking near the top portion) and VR controller. The VR controller can get stuff like switches, but NOT the fuel switch because it’s so cumbersome I usually end up accidentally shutting the fuel off. I like the mouse because the scroll wheel is handy for changing value, radio frequencies, etc. I wish that the VR controller would be less cumbersome, and offer some easier way of scrolling. The interaction model for the Xbox controller is actually pretty good, and using Xbox controller to fly is actually a good experience. It’s really REALLY good for controlling the camera drone. I just yearn for the VR controller integration to be better so I don’t have to use a mouse anymore.

2 Likes

I’m still getting this bug. Can’t load or save flight plans whilst in VR mode. Hangs the game. Can’t alt-tab to any other application or to Explorer. On launching Task Manager I can’t alt-tab to it but I can see that MSFS has ‘not Responding’ next to it. I’ve ended up having to do a forced shutdown.

Yup I have the same issue.

1 Like