VR camera angle tilted upwards in Carenado Piper Arrow

I can’t for the life of me find a way to adjust this. All the stock planes are fine, but the Arrow III camera is not properly calibrated. You are looking upwards at about 20 degree craning your neck (this is also very noticeable when you bring up a VR menu, move it to your side and the angle is so off being level)

Is there a way to recalibrate or adjust the up/down VR camera tilt? I can rest the position as well as move up/down/left/right with the keyboard, but cannot figure out how to tilt the camera down a bit to compensate

To adjust the height of the seat it is the Alt key (left of the space bar) + Up or Down arrows

It’s actually about the tilt (rotation) and not the height (position). I’ve had this happen on this plane, and the other way on the Mooney. I haven’t been able to find a fix.

That’s what I understood with a first translation, but a second gave me a high / low position. The tilt is an adjustment found in some simulations like Assetto Corsa. But the setting does not work, only when playing on screen. In VR it is disabled. It is your position when you are going to refocus the VR view that will give you this tilt. If not good, try exaggerating your inclination before refocusing the VR view

You need to add a ‘VR view’ entry to the cameras.cfg and set the pitch to zero, otherwise the game horizon will not be level with your real horizon.

I’m not at my computer right now so can’t tell you the exact path where to find the cameras.cfg file. Basically all default aircraft (and most payware aircraft if set up correctly) have a ‘VR view’ entry in the cameras.cfg. The important part of this view is that the pitch of the camera is level with the horizon.

I found the same problem with the view being tilted too far down on the FBW A320 and MB339 because I had re-assigned the default VFR view in 2D (CTRL+F10) and there was no ‘VR view’ in the cameras.cfg, so the actual viewpoint when in VR was falling back on the deault VFR view which had a vey nose down attitude.

When I’m back at my computer I can show you which path to find the file you need to edit, but in short you can copy the ‘VR view’ entry from one of the default planes main cameras.cfg and paste it as a new entry in the custom views cameras.cfg for the Arrow. Note there are 2 cameras.cfg for each plane. One is the master file which shouldn’t really be edited; the other is where any custom views are stored and should be unaffected by any product updates. Then you need to copy the xyz and Pbh values from the default Arrow VFR view but set the pitch P to 0.

Sounds a bit complicated if you’re not familiar with custom views, but it definitely works and levels out the horizon in VR. Hopefully Carenado can add the VR view in a next update as it should be a very simple fix for them to implement.

3 Likes

Hi,

Just in case anyone wants help with this, navigate to this directory for the aircraft with the VR problem (for this example I am using the MB339 because I don’t have the Piper):

\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SimObjects\Airplanes\IndiaFoxtEcho_MB339A

In that folder should be 1 file called CAMERAS.CFG. If you don’t have the file or can’t see the folder an easy way to create it is to launch the game in the plane and click CTRL+F10 to assign a new default VFR view or CTRL+ALT+1 to create a custom view. Don’t worry, you can delete this view after the file has been created.

Then copy this and paste at the end of the CAMERAS.CFG file (the text below is just copied from the default 152 aerobat, but it is in the correct format):

[CAMERADEFINITION.X]
Title="PilotVR"
Guid="{3BD57836-093A-45FD-9418-AF9636C29B8F}"
UITitle=""
Description=""
Origin="Virtual Cockpit"
Track="None"
TargetCategory="None"
ClipMode="Normal"
SnapPbhAdjust="Swivel"
PanPbhAdjust="Swivel"
XyzAdjust=1
ShowAxis="NO"
AllowZoom=1
InitialZoom=0.35
SmoothZoomTime=2
BoundingBoxRadius=0.1
ShowWeather=1
CycleHidden=0
CycleHideRadius=0
ShowPanel=0
MomentumEffect=1
ShowLensFlare=0
PanPbhReturn=0
SnapPbhReturn=0
InstancedBased=0
NoSortTitle=0
NodesToHide=""
Transition=0
PitchPanRate=20
HeadingPanRate=60
PanAcceleratorTime=5
XYZRate=0.25
XYZAcceleratorTime=0
ZoomPanScalar=1
Category="Cockpit"
SubCategory="Pilot"
SubCategoryItem="PilotVR"
InitialXyz= 0.02, 0.098, -0.675
InitialPbh= -2.5, 0, 0

You need to replace the [CAMERADEFINITION.X] with the next value, starting at .0

Keep that file open, now navigate to this location for the Carenado plane (assuming it has been installed in the Community folder. If bought through Marketplace it will appear in the ‘Official’ folder in the same level as the Community folder):

\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Community\indiafoxtecho-mb339\SimObjects\Airplanes\IndiaFoxtEcho_MB339A

Now open the cameras.cfg file in that folder and look for the entry called Title = “Pilot”. It will probably be the first entry. You need to copy and replace the lines (obviously the values will be different for you):

InitialXyz = 0.05, 0.075, -0.8 ;
InitialPbh = -2.5, 0, 0 ;

into the other CAMERAS.CFG file for the VR entry. This way the ‘PilotVR’ view will be identical to the default ‘Pilot’ view.

Now the important part, you need to modify the Pbh line so that the first number is 0. So in this example my file would look like this:

    [VERSION]
    major=1
    minor=0

    [CAMERADEFINITION.0]
    Title="PilotVR"
    Guid="{3BD57836-093A-45FD-9418-AF9636C29B8F}"
    UITitle=""
    Description=""
    Origin="Virtual Cockpit"
    Track="None"
    TargetCategory="None"
    ClipMode="Normal"
    SnapPbhAdjust="Swivel"
    PanPbhAdjust="Swivel"
    XyzAdjust=1
    ShowAxis="NO"
    AllowZoom=1
    InitialZoom=0.35
    SmoothZoomTime=2
    BoundingBoxRadius=0.1
    ShowWeather=1
    CycleHidden=0
    CycleHideRadius=0
    ShowPanel=0
    MomentumEffect=1
    ShowLensFlare=0
    PanPbhReturn=0
    SnapPbhReturn=0
    InstancedBased=0
    NoSortTitle=0
    NodesToHide=""
    Transition=0
    PitchPanRate=20
    HeadingPanRate=60
    PanAcceleratorTime=5
    XYZRate=0.25
    XYZAcceleratorTime=0
    ZoomPanScalar=1
    Category="Cockpit"
    SubCategory="Pilot"
    SubCategoryItem="PilotVR"
    InitialXyz = 0.05, 0.075, -0.8 ;
    InitialPbh = 0, 0, 0 ;

So now when you launch into VR it will pickup this view information and hopefully the camera tilt will be fixed. You might need to experiment changing the P value, because it is actually relative to the plane axis so if you have a taildragger it may not be so simple as changing to 0, but for the Piper Arrow with the tricycle gear it should work OK with value 0.

Hope this helps anyone else with the problem I was having.

2 Likes

You guys are awesome, thanks so much for taking the time to write this you’ve made my day a bit. Gonna go try it now

I don’t follow this line, can you elaborate? Everything else in the guide seems straightforward

Ok also, with trying to make the cameras.cfg file - pressing ctrl-alt-1 seems to do nothing and ctrl-f10 immediately quits the sim to desktop :confused:

i am copying a link to this thread and will send a bud report to Carenado. I was hoping they would have fixed this in the recent update they did, but i guess they did not. I get the same tilt, but in my case, its like i am leaning forward about 10 degrees. very irritating and disorienting specially in VR.

I think we should all send this to Carenado as a bug report, so they are aware of this issue

Hi Rob,

Depending on how many custom camera views you have in the file, each view will be assigned an entry like this:
[CAMERADEFINITION.0]
[CAMERADEFINITION.1]
[CAMERADEFINITION.2]

etc.

You just need to make sure that when you paste the new text you label the view accordingly.

As to the CTRL+F10 CTD, I have noticed this is a bug with the Flying Irons Spitfire. I believe it is a bug with Asobo rather than the third part developer, but it only seems to affect certain aircraft. A way around doing this is to manually create the folder and CAMERAS.CFG file (right click, new Text Document) or copy the file from another aircraft. I’ve found once the file has been created you can then use CTRL+F10 as normal.

Just a note, when you do CTRL+ALT+1 it needs to be done on the top row of number keys, not the num pad keys. You won’t get any confirmation it has worked since it is just assigning the current viewpoint as a custom view. The only reason I ask you to do this is so the CAMERAS.CFG file is created in the correct directory and format. Until you create a custom view or reassign the default view (CTRL+F10) that file won’t exist.

Hope it makes it a bit clearer.

Thanks again for your help - I was able to actually get this working in the end bypassing the first step and just going into the Community/Official airplane folder and changing the InitialPbh values in the cameras.cfg file in there

1 Like

Hi Rob,

Great you’ve got it working. Sounds like you bought the Carenado Piper through the store if the files are in the Official folder? Just a word of warning that future updates may (or may not) overwrite your changes to the cameras.cfg file. This is why I recommended to add the entry to the customs view file as this shouldn’t be touched by any updater.

But if you’ve got it working using your method and a future update breaks the VR view again, you can of course just repeat your process to modify the Pbh value.

Cheers.

Hey @sanins192
I tried adjusting the pitch on the Arrow and Mooney but no luck. Are you able to upload and post your file to dropbox or something?

Good luck getting a response or fix from them. (long time X-plane user here)

Hi, sorry, I don’t have either of those aircraft so can’t post the cameras.cfg. If you find the cameras.cfg file and just try setting the Pbh= line to 0,0,0 then relaunch the sim to see if it fixes it. Cheers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.