VR Controllers disappear and have to be "woken up" by pressing grab button very often


Are you on Steam or Microsoft Store version?


Are you using Developer Mode or made changes in it?


Brief description of the issue:

VR Controllers disappear and have to be “woken up” by pressing grab button very often. After a very short time not touching the controller it disappears. Just taking it again, or moving it doesn’t make it appear in the sim again. You have to press a button or grab trigger in order to wake it and make it appear in the game again. That adds a completely unnecessary extra step every time you need to adjust something, if you haven’t used a controller for a minute. Every time!

There’s no reason to hide the controller, it should always be present, as long as it’s tracking. If it’s on your lap or on the table in front of you - the ghosted image should be there so you can grab it easily. Instead it disappears completely, very quickly, without ability to adjust the timeout or its behavior.

This makes if very difficult to find it and demands an extra click to activate it.

Provide Screenshot(s)/video(s) of the issue encountered:

Easy to reproduce, no need for video.

Detail steps to reproduce the issue encountered:

  1. After using the controller, let it rest on a solid non-moving surface, and it will disappear after a short time
  2. Picking it up again (without prassing any buttons) will not wake it up. A trigger or grab button have to be pressed for it to “wake up” and appear in the sim again.

PC specs and/or peripheral set up of relevant:

Reverb G2, WMR, Ryzen 5900X, RTX 3080, 64Gb RAM, 2Tb SSD.

Build Version # when you first started experiencing this issue:

Sum Update 7

I’ve noticed that the VR controllers disappear the moment I use my hardware rudder pedals. Very annoying when using the VR controllers to operate the yoke/stick and throttle.

1 Like

I was thinking that it was a bug or something, absolutely a non sense step to ‘woke up’ the controllers every time.

Same issue here. If I want to use my VR controllers, I cannot touch anything else or they will disappear.

Awesome when you’re trying to fiddle with an instrument but cannot touch the yoke :unamused:

I’m with an Xbox one controller and a Quest 2.

1 Like

Same issue here. Any word on a fix or hack to keep them alive?

1 Like

same here too very annoying

It happens to me after todays update.
I am using oculus quest 2 with virtual deskop on microsoft store version, and whenever I use my joystick or xbox controller, VR controller disappear.
Have tried restarting and messing with controller configureation, none worked :confused:

The issue remains after updating to Sim Update 10 BETA, still havn’t found a workarounds yet.

Same issue here. Makes it super difficult to use the software in VR. Steam version no development mode, using rudder pedals disables VR controllers until pressed again.

Any update about this?

Not that I know of… It’s still an issue… Very annoying…

Hi there

I got the same issue.

I noticed the issue :slight_smile:

I have a joystick for using the stick in my plane.

As soon as I touch the joystick ,my VR right hand disappears. If i want to use my right hand, i have to touh any buttons and it re appears.
Very annoying as you can move the stick while diminishing the throttle for instance like you would do in real life.

is there an Asobo developper that reads this ? its probably very simple to fix…

same here. controllers nearly dont work, they disappear and come back. Reverb g2.
almost a show stopper for msfs, sorry to say.

Same issue here.

Yeah, this is brutal. Just got some pedals (wanted to control yoke and instruments with the motion controllers).

It seems to trigger when the pedals return to 0. Doesn’t make the controllers disappear when first pushing them. Only when returning.