VR Controllers - It. Just. Doesn't. Work

Latest update. VR Controller Support! Using Oculus controllers. Works great in the menus. But in the planes, I can’t do anything. I can’t even dismiss the popup dialog. I feel a vibration when I move to a button (indicating an action of some kind), but left trigger does nothing. Nor does right trigger. Both are configured correctly in control settings. But I can’t interact with the plane at all. Anyone else?

Or do I need to find a plane that has full VR Controller support? The game said that some planes don’t have it. I have yet to find one that DOES, however.

Why couldn’t they just make the controllers work like the mouse. It shouldn’t be THAT hard. Grrrr…

Any suggestions?

5 Likes

Unfortunately my download is running on 2.5 hours so i’m still waiting, which planes have you tried? I would suspect 3rd party planes may not be completely compatible as the dev needs to make it so

Also, generally speaking grabbing stuff in VR is usually done with the grip button. You also may need to set to the new style interaction (not the legacy)

Check the settings for VR Controllers as there are 2 choices for how the interaction is supposed to work, it’s in the Release Notes (worth reading). I read them and it sounds “ok as a start” but not great in my opinion, so I don’t plan to try it and will keep using mouse and yoke/throttle and keyboard (in VR) like I always have until they further advance this part of the VR experience

So far no good. I saw toggle and hold for yoke. Is that what you are forever if to? I can get the yoke to work. But nothing else.

Please look at this post: Does the VR controller support work for anyone? - #7 by tamalien

Solved it for me.

@GxM42 Unfortunately the mouse and the VR controllers will not interact with the tool bar or any of the panels that the tool bar generates, e.g. ATC, weather, VFR map etc :frowning:

As per @HeikoJ2709 post above, it appears that “lock” mode needs to be set for cockpit interaction. See the linked post for more information.

Does this fix the toolbar issue? I don’t care about controllers, I just want to be able to use the mouse. Currently I can’t access any tool buttons, weather, ATC, EFB, nothing works :frowning:

Unfortunately not. Toolbars are still not operational with the mouse in VR… i guess we need to wait for a hotfix.

Hotfix for a VR issue? I’m not holding my breath!

Well yeah I know what you mean, but this issue makes the VR mode completely useless as of now. So they might need to fix it asap.

I managed to get the toolbar working with an Xbox Controller, bit clunky but at least you can still set up maps in VR and move/resize them now and communicate with ATC.

I feel for those without an Xbox controller though as I couldn’t get it working with mouse or G2 controllers at all.

Thanks for the hint. But yeah, I mean this is a fundamental thing that just needs to work without “workarounds”… I’ll just wait and hope for a hotfix…

1 Like

Once you have figured out all the necessary settings to allow controllers to work and have acknowledged the fact that the toolbar bug is severely limiting functionality, fundamentally, VR controllers do work. But…and it’s a big but, using a VR controller with ray pointer to press buttons, set switches and twist dials is just simply not workable.

Holding the controller in the air and pointing it accurately at tiny buttons and dials seems a great idea in theory but in practice, it is incredibly difficult to be that accurate and more importantly incredibly tiring for your arm muscles.

Trying to replicate the intricately small movements that we happily make with our fingers and wrists on a mouse, with a VR controller is frustrating, tiring and pretty much impossible with your arm held out in front of you.

On top of this, using the tiny thumbsticks to control a yoke is really difficult as resolution of control is way too small. Also adjusting radio frequencies in VR usually, for me anyway, requires cockpit zoom to be able to see the numbers you are trying to adjust. Can’t point and zoom at the same time so, you can twiddle away as much as you like but you can’t see what you have selected.

After five minutes of trying this I realised that I will not be pursuing this avenue any further.

I feel a little bit sorry for ASOBOSOFT as I believe VR controller functionality in FS2020 was top of the VR wishlist from the community and must have taken a huge amount of effort to implement. Not only is it IMHO, a non-starter, it has probably resulted in several new bugs being introduced in this update which has enraged VR users all over this forum.

6 Likes

What amazes me is that there are examples how a proper VR implementation should work in a flight sim - Aerofly FS for example. But even DCS or X-Plane. I don’t understand why Asobo tries to re-invent the wheel. Just copy the approaches that work.

Same goes for other aspects of the sim, like controller mappings. Just look at X-Plane or DCS.

3 Likes

Works for me with valve index quite well. I can control the plane very accurately. Touchdown like a feather, no problem.

I needed a moment to figure out that you need to switch to LOCK interaction mode in accessibility options.

But i have also discovered some issues that needs to be reviewed maybe.

  1. It’s difficult to grab and interact with small knobs and buttons. The grabbing proximity is maybe too small. The zone around the button or knob or lever is very small and it takes some efforts to hit it. Even the flight controls are difficult to grab without looking.

  2. Tuning knobs, using small buttons is almost impossible. Doing anything with small knobs like using the G1000 knobs is mostly fiddling around, no any precise input possible yet. There needs to be some solution for this. Right now i can only use levers and flight controls with good precision. Anything that is smaller then a flip switch is already difficult to hit. Any turning knob is pretty much useless. You can turn it but not precisely. It just goes crazy.

  3. Biggest issue is with the trimming. The trim wheel such as in C152 is also very difficult to turn precisely, same problem as with the knobs, although the trim wheel is big and is easy to grab. When you turn it or move up/down it goes crazy like the knobs. It can suddenly jump up to +20° trimming and then suddenly jump down to -20°. Any precise input is basically impossible yet.

To work around (3) i have mapped trimming to free controller buttons.
Any IFR is now not really doable with small knobs being unusable. Its extremely difficult to set up IFR instruments, manage the flight plan etc…

But for VFR, when it only comes to working with the primary flight controls, flaps and gear, its working really good. I can fly it quite accurate with the virtual joke and its hell of a fun.

I wished it was possible to twist the virtual flightstick or joke to operate the ruders, like in VTOL.

1 Like

I use oculus rift s and vr controllers work fine in cockpit!. And I can click the toolbar too!

Only thing I had trouble with was the mouse and trying to press space to centre view.

Only way I could centre view to start is to press x+a on the controller’s.

Maybe that’s why my cockpit controls works fine??

Hello everyone,

my mouse and VR controller didn’t work for me either. However, the windows under VR can be switched off under the menu item Difficulty level in the 2D view because after the update my entire difficulty menu was reset, I have now set everything to be difficult again. Take a look at the individual menu items as not everything is reset to difficult and then switch them off in the difficulty setting submenus! If you now switch off the VR controller you can use the mouse again to control the aircraft and the menu and everything is at least usable as before the update. That with DR VR controller support was a letdown but if it should stay deactivated it should work, at least that’s how it works for me!

Perhaps you have switched your cockpit interaction mode to LEGACY after last update?
If so, switch again to LOCK mode, then both VR controllers and mouse should work with cockpit items and also with windows and menues.

I had same issue. And messing about I managed to get control and could interact with controls with both hands.

For I while I could figure what I did bit then I just managed to replicate it

Start game, click fly, then open the menu with b button on right touch controller.
Use the mouse to move the throttle control a little.

Then try your vr controllers. Mine then start to work fine with all interactions to the cockpit controls.

Hope this helps someone.

Did you all see the other posts and youtube videos on the workaround for the mouse not working with the Menu at the top of the screen while in VR flight…you can just hit Control-Zero (0) and it apparently will then allow the mouse to again interact with the menu at the top in VR. FlightSimGuy on youtube did it in his video a few hours ago and it was also commented on here in the MSFS forum by another user…not sure why it works but if it does that’s great and it’s a workaround for now.

1 Like