VR issues - Oculus Rift S

Try the registry edit listed in this thread: [Read First] VR Known Issues & Workarounds

I’m very curious how everyone assigned a button to recenter the view in VR. The option is there in VR Options menu, but when I click it nothing happens. It doesn’t allow me to assign anything

For people with Rift S, Experiencing either issues with: Recentering in FS not moving to centre, Recentre message not dissapearing, and sometimes just viewing a black screen;
I have found that sometimes if it is not behaving as it should, I have to press the oculus menu button, recentre the view in the app through Oculus, and then press the spacebar once back in FS to recenter the view there, then all seems to work as it should. Not sure why this is but it suggests to me that Oculus and FS have seperate coordinate/recentre systems running at the same time. Either way, once I have done it the first time, I haven’t yet had to do it again in the same session.

1 Like

What does it it mean when it says “ 1. For ActiveRuntime change its value to the one that matches your platform (note: default path is shown below):
C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json”? It already has that file directory and it still says headset not found. Am I supposed to change it? I don’t understand what I need to change it to.

It is giving you an example of the default location. My “oculus_openxr_64.json” file happened to be there so I just copied that location and pasted it into the box. Your file might be installed somewhere else so you’d just have to search for it in file explorer and then put the destination into that box

In Oculus debug tool turn FOV Stencil to Off. Fixed it for me

Okay, if anyone in the future is having this problem you don’t need to pull up registries and all this stuff. Just go to steamVR, settings, developer, and change “Current OpenXR runtime” to SteamVR. Fixed it for my Valve Index headset.

I have done all the things on here. Openrx. Oculus tray tool. Lowered setting to medium etc etc etc. Fly a GA in Tokyo…f*#kin 12fps!! What the actual fup!!! Are they fupping kidding me!!! If I had a ■■■■ low end machine I’d be ok. But jeeeeeez!

Yeah did that and now my vr headset won’t even work. Black screen!!! Cheers!

Updating Oculus software to public test channel fixed all my problems.

It’s just so very poor. FPS are shocking. Even on medium settings. With some even at low. And I have a very decent machine!

Has anyone found the solution for no plane sound? I have UI sounds but no plane sound.

If you watch some of the youtubers out there they explain how to use a vr graphics option in the general menu. I have a oculus rift and I do not see it on my menu. However, all the option are there that they demonstrated and are in a nice menu. The vr graphics menu is not hanging out as a separate option on the graphics menu but located at top the graphics menu. At the top of the graphics menu you will see PC with two blue arrows on each side. Click on the arrows and that will change it to VR graphics. That way you can configure you VR separately from your PC.

I’ve been messing with settings and went all the way to low on everything. Still getting 10FPS or less. Oculous Rift S. I feel even in PC mode I am getting super low frames all of a sudden. Wow this is bad!!

I’ve spent the last couple of hours tweeking and I think I have it set to a comfortable level that balances quality and performance.

First, my rig (Good, but not superb):

  • Intel i7-9700K overclocked to 4.7GHz
  • 16GB Ram
  • Geforce GTX 1080 Ti, also overclocked with an MSI Afterburner profile
  • Oculus Rift S

I first did the update to beta version of Oculus software, then turned off the “Use FOV Stencil” to get rid of the black thingie on the screen.

I then actually set my Rift software to prioritize performance over quality. Why? Because I want the tray tool and game to deal with resolution. I may change it to quality after a while to see if it changes anything, but I still find I can read the instrument panel just fine.

In the Oculus Tray Tool I run these settings:
Super Sampling: 1.2
CPU Priority: High
ASW Mode: 30 Hz (what? why 30? I tested all the modes and this was the most smooth for me. YMMV)
GPU Scaling: On (I found this to cause less jittering)

If you are using a profile in Oculus Tool Tray, make sure the EXE Path is correct (mine is D:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe) and that you hear “Game Launch Detected” when the game starts. You can verify the proper settings are being used by monitoring the log window as you launch the game.

For in-game settings, the two most important for me were to set the render scaling to 100. Anything less and it’s too difficult to read the instruments. Anything higher and you start to lose FPS quickly. Let the 1.2 Super Sampling be the thing that ups the quality. You can play with these two things to see how things behave for you. Trial and error will find a good balance. Also, I use TAA for anti-aliasing. All the other options created too much noise.

As far as all the other in-game graphic settings, it’s all about what you find most important in regards to quality vs. performance. Play around and see what works for you. I cannot run very many things higher than medium here, but I’ll probably spend a few days turning things up and down and seeing what causes the most hits in performance. Happy flying!

Edit: Just wanted to say that I always seem to start in a weird position, but hitting the space bar for me sets me in the pilot’s seat. Then I can use the arrow keys to make any minor movements. If the keys aren’t working, click anywhere on the screen with the mouse…you may have lost focus when switching to VR.

9 Likes

The old camera translation still works. I bind buttons for camera moving up, down, left, and right, forward and backward in addition to reset. I can move my eyepoint without anyproblem

Ok so this worked for me once I also downloaded the Oculus beta.

Cheers,

Nice writeup. The only issue I’m having with following your settings is that I bought flight simulator via the MS store. I found where the flightsimulator.exe is but the system won’t allow Oculus Tray Tool access to it. All the other settings I can set as global but the cpu priority seems to be profile specific.

In any case, I’ll try the settings you’re recommending.

Cheers,

1 Like

Could you provide the link for us please?

Ive been looking all morning for the link to Oculus V24 beta, could someone send the link please, having real trouble finding it.

Thank you.