VR issues? - Pimax

Initial issues?

„No headset found issue“ -> Select Beta mode for SteamVR, and validate the message from SteamVR asking to make it the default gateway for OpenXR that appears when you relaunch SteamVR. Next time you enable VR mode, your Pimax headset will be found.
Thanks to SweViver😉

Turn OFF: Windows „Game mode“ and „Hardware accelerated GPU scheduling“ and „G-Sync“. RESTART,RESTART,RESTART!

Use Pitool V1.0.2.087 and Pimax Experience 0.84
Make a new room setup in Pitool.

Turn HDR ingame OFF
Press Spacebar ingame to recenter the cockpit sight.

After all changes RESTART!

Otherwise you may find the answer you need here:

1 Like

I own a Pimax 5k+ headset. I can’t get it to work with MSFS. PLease help!

I have a Pimax 5k xr with PiTool and Firmware I have SteamVR running and see the “home base” in the HMD. First time I tried to switch to VR mode the HMD went black and in MFS I saw some grayish wireframe screens with gray canvases… Switching back to normal screen mode worked. I then tried to install the OpenXR drivers and configure it like it says in this forums FAQ. No luck. Now when trying to swtich to VR mode I get a window which says “no HMD detected” in MFS.

any ideas ?

Hi there.

I just tried with my new Pimax XR - no settings changed what so ever and it just worked straight after enabling VR in the options menu to my surprise - yes the performance isn’t great but what an immersive feeling :smiley:

I am on latest drivers and firmware on 5950X and RTX3090 FWIW



I was getting black screens if final render resolution (Pitool Render + SteamVR SS) was too high. Check in SteamVR that vertical render resolution is around 2500p and work from there.

First Aid is to turn OFF: Windows „Game mode“ and „Hardware accelerated GPU scheduling“ and „G-Sync“.

Best regards

Thank you for the tips. “Game mode” is off… not sure where to find the two otter settings. In MFS ?

I cannot find that on my system… only below

Also interesting I don’t have any “GRAPHICS VR” menu in MFS…

Here is a tutorial😄

Thank you for the tip but my “graphics settings” looks like above screen shot. There is no “Hardware accelerated GPU scheduling” to turn on or off…(My Windows version is 1909 Bulild 18363.1198) Basic question does the Pimax also need the OpenXR drivers ? or could they be cause issues ?

if you enable the steam VR beta openXR should be enabled. However, this didnt solve the problem for me

What a way to spend the evening… I installed these Pimax drivers… https://community.openmr.ai/t/pimax-vr-experience-0-84-0-0-beta/33810 Then managed to enable PimaxVR Beta. It did not change the version number still 1.15.15 but it realized that it’s not the primary OpenXR (was it driver or application ?) So it set it to primary then started MFS again… now I can again switch to VR mode and see a beautiful yellow color in my HMD and again just some wireframe stuff in the MFS window.

Maybe I should just call it a day and wait for 3-6 months til this is fixed… :nauseated_face:

Its so frustrating. I have the Pimax betas as well, but as I underdstand it, the OpenXR is enabled by checking the beta tab for Steam VR. Make sure in steam that you can see tools, then enter properties for steam VR and select steam VR beta

Interesting… In game I can switch to VR mode and it displays correctly on the screen… but the HMD displays just turn yellow, like’we done before. Tracking appears to work.

I heard HDR causes similar Problems. Did you turn it Off in game?

I saw the thread on the yellow HDM screen for the HP Reverb. After reading that I switched off HDR in Windows. Now it works for me as well. So the basic VR functionality is there now. It’s running quite smooth so far… but there are still some display issues mainly in the peripherals. But at least I’m releaved that basic functionality is working now. Only took about 4 hours 30 mins to get going.

1 Like

I can’t get by the RECENTER screen. I’ve tried mapping the VR Center button but no matter what I select it doesn’t do anything when I press it. Other than that the menu looks great in VR :smiley:

1 Like

I have the same problem. Xant’t map a button to the cockpit toolbar either

I tried to start a flight and them switched to VR mode thinking i might get by the recenter screen but it appeared in the middle of the screen, at least I was able to look around the cockpit in VR mode :smiley:

1 Like