VR not working with Open XR (Reverb G2)

Whenever I try to enter VR mode with OpenXR enabled, the sim enters VR mode for a second, before reverting to normal. There are no error messages / explanations as to what has happened, there is no CTD either. If I use SteamVR, without OpenXR enabled, I can enter VR mode with no problem. This is not ideal however, as I would like to optimise my VR experience by using OpenXR.

On one or two occasions (with OpenXR enabled), I have been able to enter VR mode, but I can only see black in my headset, and I can see that the screen doesn’t move when I move the headset (in other words - it seems that MSFS and the headset aren’t linked).

Within regedit, I have the following - HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1 pointed towards C:\WINDOWS\system32\MixedRealityRuntime.json. VR simply will not work when this is the case.

If I use SteamVR and point HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1 towards C:\Program Files (x86)\Steam\steamapps\common\SteamVR\steamxr_win64.json, VR DOES work, but as I explained, I do not want to use SteamVR without OpenXR.

If I enable OpenXR within SteamVR, the regedit changes back to C:\WINDOWS\system32\MixedRealityRuntime.json and VR no longer works.

I have HDR turned off in Windows and MSFS, if that makes any difference. Any help would be much appreciated so I can finally use Open XR to optimise VR properly, cheers in advance!

System specs:

GTX 3090

It sounds like you are using the OpenXR Developer Tools. If that is true, go to the Developer Settings tab and disable “Use latest preview OpenXR runtime”. I was having issues until I disabled that.

Thanks for the suggestion mate, unfortunately hasn’t worked. Just prior to doing that, I was getting the black screen as described above. After disabling ‘Use latest preview OpenXR runtime’, it goes into VR for a split second and then reverts to normal (as also described above).

If yourself or anyone else has any other suggestions it’d be much appreciated!

Here’s my settings. Good Luck

There’s some interesting reading on this thread

Thanks again, unfortunately hasn’t worked :frowning:

I wasn’t sure what you meant by enabling OXR. That would be the normal op mode with the G2 with the store version of the sim. Not knowing how long you’ve been using the G2, I thought the thread link would familiarize you with some of the oddities like the low voltage USB conditions that are solved with a powered USB strip. And then there’s the bad cables with the original design. I’m on a replacement cable. As far as OXR and the developer version, you can uninstall and reinstall from the MS Store. That assumes the registry is still in it’s original state. I’ve had times when the HS doesn’t switch to VR with the keyboard command but a repeat usually wakes it up and works. Hope you narrow down the issue. WMR/OXR should work out of the box.

In WMR set openXR as the runtime then uninstall SteamVR. See if that works

Your suggestion worked for me. Not sure I was having the same problem as the original post. I would be able to go into VR, stay in VR, but as soon as I switched out of VR, I could not get back in. I had the message of make sure you have Open XR enable, or something like that. Once I switch to disable latest preview on the Developmental Tool setting, and shutdown and restarted the sim, this problem as gone away, and I can freely switch back and fourth.

1 Like

I had the same problem until i disabled the latest preview option … Must be a bug as this issue did not happen prior to OpenXR being updated