Warning: Your graphics device has encountered a problem

Today I actually got to take off and climb to 14.000 feet before hitting a CTD…

MODERATOR EDIT:
This post merged into this topic.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Yes

Brief description of the issue:

After loading flight, get the attached dialogue and CTD. Currently I am unable to get anything into the air. Fresh download/install of new Nvidia driver today 22 Nov 2022.

Provide Screenshot(s)/video(s) of the issue encountered:

Yes

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

B550M Ryzen 5600X 32GB RTX 2060 2 x 1TB NVME

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Build Version # when you first started experiencing this issue:

Today


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Do you have the same issue if you follow the OP’s steps to reproduce it?

no

Provide extra information to complete the original description of the issue:

I even have no possibility to set anything because app becomes inoperative before it

Are you using DX12?

no

Are you using DLSS?

no

If relevant, provide additional screenshots/video:

no

Exactly what I have done. Even add a full Windows reinstall on top of that.

Same results. So it’s somehow tied to the hardware of my system. 5950x, RTX3090, 64GB RAM, 5120x1440 monitor.

No overclock, no plugins, as vanilla as you can get. And I can only play for five minutes, tops. It’s been like this for months. :man_shrugging:

I feel your pain. As you’ve reinstalled Windows I’ll just mention HAGs is on by default and maybe off can help. I’ll also advise against the 522.52 driver and maybe setting NVCP debug mode.

i managed a 2 hour flight yesterday out of the blue - HAGS on, dx12, latest drivers and msi afterburner used to max out power and temp limits.

tried combinations of HAGS on/off and dx11 on/off today and still getting ctd roughly after 15-30 mins on the ground (not bothering to fly just leaving it on and waiting for the CTD).

currently testing HAGS on, DX12 and power/temp limits maxed out to see if i can reproduce the stability from last night.

btw can anyone here help debug the crash reports we get from windows event viewer? maybe they have a clue? i have tons of them

UPDATE: HAGS ON, dx12, msi afterburner on - no ctd for the last 45 mins.

others can check if this solution works for them. i prefer dx11 but i guess beggars cant be choosers

Something else that you might try is reducing your display resolution to 1920x1080. Of course you need to match this resolution change in MSFS settings.

It isn’t very intuitive, but I have found that my 2K 120hz system actually runs noticeably smoother with the lower resolution settings and a 60hz refresh rate. ( I was even able to uncap the FPS everywhere with no VSYNC anywhere.) I get 99 % green FPS graphs in developer mode with it providing around 55-75 FPS depending on proximity to add-on airports. (RTX 3070)

I know, you have a nice high-resolution display, and you shouldn’t have to do this. I agree 100%.

But as they say, desperate times call for desperate measures until they (?) come up with a universal fix for this issue.

Interesting, I’m going to have to try flying without afterburner on, see if I can get the message.

Letting MSFS run unchecked at 600fps in the menus is not the best idea so enable low power mode in General Options / Experimental. It does not affect performance while flying.

1 Like

I only get this message when flying over New York. CTD on 3 flights already…

I have lowered my render scaling and set my graphics to medium as well, even lower on the last crash.

AMD R7 3700x, Radeon 5700xt, 32GB ram. Samsung NVME 1tb drive.

I went back to Windows 10 and have been flying nonstop for 24hrs now with no issues.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Receive the same error message upon booting the game. Cannot get into the game to change any settings

Are you using DX12?

Yes

Are you using DLSS?

Yes

If relevant, provide additional screenshots/video:

Using the new multi monitor experimental setting with 3 total monitors. I received the error message upon switching to DX12 from DX11 for the first time. Now I can’t get into the game to change back to DX11 under which I didn’t have any problems and never received this error message.

Update: After reading on this thread to try closing Afterburner I did that and can now boot into the sim without receiving the error message. I’m switching back to DX11 to see if that eliminates any future error messages/crashes.

Update 2: Closing Afterburner was the ticket for me!! I was able to get into the sim and change back to DX11 and haven’t experienced the error message since!

1 Like

This post was flagged by the community and is temporarily hidden.

1 Like

The popup with the error message wrong graphics driver or overclocked graphics card must have been installed by the programmers of the FS, otherwise it would not open and cause the FS to close! So the programmers must also know at what point in time and what error feature this popup opens! Now I ask myself if I rarely had CTD’s before the updates and always had a smooth gameplay, why is Microsoft now forcing me to switch off the overclocking of my graphics card, which neither gets too hot nor is it overwhelmed by the SIM, or not to switch off the programs intended for this, such as Nvidia Afterburner more to use? For me, that stinks of commerce and nepotism to buy a more powerful card after the new cards appear, because it worked before.

Still getting this on every flight loading screen in DX11. Capped my menus frame rate at 60 so it shouldn’t be a resources issue

Crazy they have not fixed this yet