Warping/distortion effect with Reverb G2

I everyone, I just joined this forum hoping to find some help.
I have just received my HP Reverb G2 headset, I specifically bought it to play MSFS.
I have installed Open XR and following some tutorial, I have set the Resolution Scale to 70 and enabled Reprojection.
In the game, I also set the render scale to 70 in the VR Graphic options, and set most of the details to high or medium (I have an RTX 3080, Core i9-10900K)
The game runs pretty smoothly, but there is this HORRIBLE distortion/warping effect along the edges of the plane when I move my head quickly. Or if I go in the external view and I spin the camera, all around the plane, I can see this weird warping happening. Its very distracting.
Is this normal?
Is there a way to reduce it/remove it?
Thank you.

I’d try it with VR Scale in the sim at 80 and the OpenXR like this (it’ll automatically do the render scale with a customised scale switched off). Try it with a GA aircraft with steam gauges to start at some tiny out of the way airstrip.

And then increase the in sim scale to suit, suggest you’ll be able to get to 100 without issue and then you can start to raise the other graphics settings whilst flying from more and more built up areas.

I run that on a 2080ti / i9-10850K and is pretty smooth.

Thanks I will try this settings. I have few more questions:

  • Do I need to restart the Sim every time I change Open XR settings? I think I have tried changing it while the sim was running but didn’t seem to have any effect.

  • Does it matter if the game is running in Window mode rather than Full Screen?

  • Do I need to launch Open XR every time I play? Or once its set, I can close it?

Thank you.

Restart sim and the G2 after changing things in OpenXR. Not sure if you have to, but it is the way I do it. My understanding is that OpenXR tool only configures the runtime for VR. The runtime itself handles the graphics once under VR.

Windowed mode or full screen doesn’t seem to make any difference. What you’ll see on your monitor is only a mirrored copy of what the G2 sees so should really affect FPS.

Once you have set the settings you want in OpenXR I never run it again.

That is my understanding anyway but no doubt I’ll be told I’m doing it wrong :grinning:

1 Like

Sounds like the effects of Temporal Anti Aliasing. Try FXAA instead, but the trade-off is significantly worse image quality.

Thank you!

1 Like

Do I need to restart the Sim every time I change Open XR settings? I think I have tried changing it while the sim was running but didn’t seem to have any effect.

No you don’t. You can make OpenXR changes but they they will not get picked up unless you come out of VR and back in again (Ctrl-Tab mapping for me). Please be aware if you save a new setting in OpenXR and it crashes, it’s likely because MSFS or another application is using it and therefore is unlikely to have saved that change.

Does it matter if the game is running in Window mode rather than Full Screen?

Generally no, but there are some visual text scaling issues if running in a small window, so the text in the World and VFR maps and popup windows are fuzzy / low resolution if the window is small. Sometimes in poor light I used to make the window small to help with motion sensors in the G2, but because of the scaling issue I now just turn off my monitor - but I don’t need to do this everytime.

Do I need to launch Open XR every time I play? Or once its set, I can close it?

Once you have configured OpenXR how you like, that’s it - no need to load it up everytime you play, it’s used automatically.

1 Like

I don’t think its the AA, it looks like a reprojection artifact of some sort. But I find strange that nobody is reporting it.

1 Like

Hey @Rikkardo77 this sounds like motion reprojection which you’ll see along surface edges especially the wing and prop and is a lot worst if moving your head quickly. Do you have motion reprojection enabled? Are you definately using OpenXR? Did you buy the game on Steam - it could be using Steam motion smoothing instead?

There is a registry setting which can confirm if OpenXR is being used, be careful how you change it though, have a look at this topic.

1 Like

Yes, it’s normal. Disable reprojection to resolve it.

1 Like

Or achieve stable and consistent 90fps - good luck with that one :grinning_face_with_smiling_eyes:

1 Like

I would love to at least get 30FPS in VR!
:rofl:

Thanks everyone for the replies, I turned off reprojection and the problem went away. :slightly_smiling_face:

Last question: is there a way to display FPS (or some form of performance analyzer) in VR?

1 Like

You can tick “display frametime overlay” in the OpenXR app but it will be uncomfortable. Otherwise you can keep the developer mode on in MSFS and check the framerate from time to time on the monitor.

Untitled

1 Like

I’ve found I can reduce the warping/ distortion by changing the vsync in the nvidia control panel to adaptive

1 Like