We need a HOTFIX for CTDs - Sim Update 5

The sim had been working very well for me…until yesterday. Hadn’t had a crash in months. Now it’s happening all the time. Sometimes CTD, sometimes BSOD, sometimes just freezes and have to force shutdown. I have nothing in community folder so that ain’t it.

1 Like

TAKE THESE CONSOLE FROM THE SERVER FOR THE LOVE OF GOD! I can’t take it anymore to arrive at the airport and the guys are running low

The guys are running low???

How does anybody expect Asobo to make changes based on this kind of feedback?

…and without the constant fear of a random CTD. That’s what kills the joy of this sim.


I’ve had no issues until SU5. I can’t spawn in at large airports (I’ve tried Heathrow and JFK). I’m using the FBW Dev version but my sim still crashed when using a Cesna 172 - In this I at least managed to get 5 miles from the airport (EGLL) before a CTD.

I appreciate the work the Asobo team are doing but I wanted to add me vote towards getting a hotfix for this asap. I literally can’t use the sim at the moment its so broken.

Another thing - I also get massive pauses on the game menu, then it unfreezes/wakes up and I can then navigate the menu’s again.

My system:

32gb Ram
Asus Strix 3080

1 Like

Takes me at least 3 tries to get into game without a CTD. Sometimes on startup, sometimes in the menu.

1 Like

Same here! Have not had any issues with CTD until SU5. Community folder empty before update, but now CTD nearly every time - sometimes on map, sometimes on flight loading sometimes on runway ready for takeoff. Only managed 1 flight so far. HOTFIX PLEASE!!!


It is impossible to fly continuous CTD, before the SU5 I almost never had CTD


1 Like

Asobo is in the position to do whatever they want because there isn’t any competition. We are like sheeps, ever more and more people buying the sim on PC and Xbox, desperately hoping bugs will get fixed.


1 Like

Hangs at the load screen after I click the FLY key. Blue bar goes all the way across then nothing.


I had a similar issue and discovered a tree lod mod I had loaded was the reason behind it.

Removed it and she’d at least load to the airport.

Good luck

Mine doesn’t even crash - it hangs on loading the scenery - happened when trying to load in EGLC (London City) but rural airports like EIDL (Donegal) are fine.

1 Like

Same problems, this sim literally never crashed for me before this update. Now I’m literally desperate. I was looking forward for this update since it was announced, but now I can’t just play the game at all. Please Asobo, give us at least some announcement that you have registered this issue and are working on a hot fix, because now we just don’t know when we’ll be able to play this game again.


just flew the FBW A320 from KSFO to KLAX and what looked like being the first flight since update without CTD it still crashed the moment I turned into my parking spot.
I can sit on the Apron for hours, but wasnt able to complete a full flight since yesterday on more than 10 attempts.

As others stated, this happens without any Mods as well, abd I am very optimistic that it has nothing to do with my settings or hardware, as till CTD I’m getting 60+ FPS and RAM and VRAM not even utilizes by 50%.

And no, turning off AI or Multiplay is not a solution.
Those are integral, important parts of the sim that simply have to work.
Just like live weather and photogrametry.
And when one of this servces is temporarily down, than this should not cause a CDT. This has to be sorted on the server side, not on the terminal side…

I am genuinly disapointed with this update.
When it is working, it does not give imorived CPU utilization but still has one core at 100% and when it is crashing, all the updated stuff is worthless.

I cant care less for 20% more FPS when it comes at the cost of stability with CTD on every single proper flight…


Never had a crash ever and zero since this update released yesterday. Installation went smoothly and the FBW A320 is as great as always. A few hours in- No CTDs.

Why am I writing this? Well people here are blaming Asobo and how could they release it in that state but clearly the sim does work at least for some - probably most - since only those with problems are likely to post.

Check your community folder addons (a couple of posts up someone just said a tree addon caused their CTDs) and your overclocking. They are the two most common causes based on the solutions posted by others.

There could be scenarios in MSFS that could cause CTD but all I see here is people complaining rather than providing helpful info such as specs, addons installed and what actions were being performed at the time - which might help Asobo find and fix it if it’s a problem in the sim.

1 Like

you;re lucky. Most have had CTD’s with every new update. I have. They do iron most of it out eventually

Same as above users, no real issue until SU5, Cannot fly more than 8 minutes before CTD. Have tried all of the remedies posted so far. I really like the visuals, clarity and increased performance but am unable to fly more than 8 minutes at a time.

Even turned my OC back to standard with the same results.

EV does not show a culprit.

1 Like

Same as most others here - I’ve very rarely had a CTD before SU5, but I can’t fly for more than 10 minutes without the sim seeming crashing back to desktop.

I’ve cleared out my Community folder, my i7-3770 and my 2070 aren’t overclocked. No shortage of RAM or disk space, but still the CTD’s keep coming… It’s frustrating because the framerate seems to have improved quite a bit.

1 Like

Really sick of this now, I know the Beta testers are doing all they can, but we have all spent a lot of money on this sim and here we are a year down the line with a product that crashes and has more bugs than a stray dog. Yes, it’s a complex piece of software, but there are thousands of other complex pieces of software out there that arent having the same problems.
Promotional videos and pushes to get people to buy Xbox versions are all very well, but there are thousands of us that still cannot use the sim properly. Look at the list of bugs and the reports going to Zendesk … when is this going to be sorted out properly? If the update isn’t working properly … don’t release it! Sorry for the rant guys , but its starting to really annoy me now.


SU5 has just ruined a great sim! Not only did it take over 8hrs to download and install (even with a fast connection) but it broke all functionality of the sim. Issues thus far after only 30mins of use:

  1. Lost key pairings with Alpha Yoke
  2. Buttons dont light up when pressed
  3. CTD
  4. Ridiculous new interface where everything lights up blue/ yellow when hovered over

I have not had the heart to even try flying the aircraft yet but have decided to just turn it off and give up!

I hope its fixed soon - or allow us to revert back to 26th July and the great product it ONCE was.

Someone at MS/ASOBO hopefully is reading this thread.


I agree. Update V stinks. I’m having same problems with CTDs. Also, autopilot is weird. Airplane on “NAV” will not follow the red line on the screen. Another issue, I hate the way the controls light up in blue. Have not found a way to get rid of that. Finally, formerly you could just punch the HDG button, and the little “bowtie” would line up with your present heading. I can’t get it to do that. Again, update V stinks. We need a fix ASAP.