Weird vision in VR

So i just got a new PC recently. Now i´ve got a problem playing MSFS 2020 in VR with the Rift S:
Hard to describe, but when i turn on VR, it seems like the environment ist moving as i move my head. Feels a bit like some zoom effect or something.
I didn´t have that issue on my old PC.

Someone had that expierience?

I checked it from an outside perspective.
It seems like when i move my head down the whole “screen” gets streched and vice versa.
Also when i move my head left/right, the plane (actually the vision itself) moves along a bit.

Same here with my G2, did not happen with Oculus CV1.

If anyone plays DCS in VR…
When i´m fully zoomed in in cockpit view, it´s exactly the same effect.

Strange. I have Rift S and I don’t believe that I have experienced that. I posted small 3 min flight over the Netherlands today if you want to compare performance.

I didn´t have that issue on my old PC neither with the Rift S.
Also, it´s not really visible on a screen. I had to have my Headset on to expierience that effect.

Make sure you have disabled other tracking software. I encountered what you described when I started MSFS2020 with TrackIR active.

There´s no other tracking software active.
The only thing i realised is that when i start FS 2020, both the Oculus software and steam VR open up.
That was kinda strange for me, but i really can´t remember if that was the case on my old system.
When i try to quit Oculus, FS 2020 crashes. So it wouldn´t run without both i assume.

Change your openXR runtime to the Oculus one. What you’re seeing happens with Oculus devices when you’re using the steamVR version of openXR (unless you’re using a Quest 2 with Virtual Desktop, to really confuse things).

Anyway, don’t worry about all that. You just need to set the registry key for the openXR runtime to point at the Oculus file and your problem will be gone.

Here are the steps if you don’t know what I’m referring to. The default path in the instructions below is probably correct for your system if you installed the Oculus software to its default location:

  • [Oculus] Before using VR in Flight Simulator with an Oculus headset, the computer needs to know the location of the OpenXR runtime to use. Please follow the steps below to set this location in the registry:
    1. Right-click on your Start menu and select Run.
    2. Type in “regedit” (without quotations) and hit Enter. This will launch the Registry Editor.
    3. Locate the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1
    4. For ActiveRuntime change its value to the one that matches your platform (note: default path is shown below):
      C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json
    5. Close the Registry Editor. You are now ready to enter VR with your Oculus headset.

You get the same effect in OpenXR if you have reprojection enabled and render scaling in OpenXR lower than 65% If it is this, then turn up render scaling.

That’s true for some other devices but doesn’t apply to Oculus. It might be ultimately rooted in the same cause at its core, but the openXR Tools installation is not needed for Oculus devices and afaik doesn’t even have any effect. Oculus software installs with its own build of the openXR support, which is what the reg key I listed above directs it to. It’s also compatible with the steamVR version of openXR, but you get the weird distortion OP mentioned (unless you are using Virtual Desktop, which requires you to use the steamVR openXR runtime, but does not suffer from the distortion issue).

1 Like

Hooray for SwirlyMaple7!
Exactly that was the issue!
Silly me! I thought of that before but didn´t change it yet b/c in DCS it wasn´t a thing.
Amazing, thanks mate!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.