What About Darwin?

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:
We just had SU VII, enhancing Australia. Nevertheless, it seems that the city of Darwin, Northern Territories, is missing. To make sure, I checked Google. The coastline and estuary where Darwin is located are well-rendered, but there is nothing but wilderness on the peninsula where the city os supposed to be. How is this possible?
Location of issue:
Provide Screenshot(s)/video(s) of the issue encountered:
Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:
Not relevant
Build Version # when you first started experiencing this issue:1.22.2,0

I arrived in Darwin this afternoon, using the latest update. After landing I had a look around with the drone and was disappointed with the quality, given that it was supposed to have been “worked on”. I usually have photogrammetry switched on but frankly it was terrible so I turned it off, which improved things a bit. There were plenty of buildings etc. around so not a wilderness, but I don’t know what I should have been seeing. Can’t say if it was a “city” or not as it’s the first habitation I’ve seen in Australia.

So I exited and loaded a third-party addon which was for the airport but as usual also included a couple of miles around. This was much, much better but obviously not complete coverage.

Darwin is there, so I don’t know why you could not see it. I presume you’ve tried the usual tricks, empty the Community Folder and clear the rolling cache. Not something I’ve ever heard of before.

Lots of Darwin there

Did you download it from the MSStore, and then install it from the Marketplace?

Optional World update content (via the in-game marketplace)


Photogrammetry Cities

  • Sydney
  • Melbourne
  • Brisbane
  • Hobart
  • Adelaide
  • Perth
  • Cairns

** Darwin*

  • Townsville
  • Mackay
  • Bunbury

Hand-Crafted Airport

  • YLRE – Longreach
  • YMBT - Mount Beauty Airport
  • YPBO – Paraburdoo
  • YSHL - Shellharbour Airport
    Above is from Release Notes

No. I just screwed up. Following the coastline from the south, I was searching in vain on the wrong peninsula. Darwin was there tonight.

1 Like

See my reply to the other post. My bad.

Topic closed