What settings to use for best FPS? Please help!

Can someone please help me. I love the sim, but there is something that really annoys me. Tiny stutters which are very clear when taxiing on airports. Mostly happens when making turns. It is not a very big deal, but it just annoys me especially with the high end system that I have.

This is using the FBW A320X.

I was running higher FPS before this new sim update 4. Around 38-45 FPS on ground, but tiny stutters were still there. Now with this new update I’m around low 30’s fps.

I’ve heard so many things to do such as turning on game mode but nothing seems to work. Also tried some settings on the NVIDIA control panel but still get same FPS.

I’m getting around 32-38 FPS on the ground. One I’m in the air it’s a smooth 50-60 FPS. I don’t mind getting 30 FPS, just as long as it is SMOOTH!! But I get these tiny stutters like every 3 seconds when making turns on taxi.

I’m hoping someone with a similar specs as me can share some settings that can fix this?

Or is this just the way the sim is right now and we have to live with it?

My specs:
RTX 3080
3440X1440 Ultra Wide Monitor

Running on mostly ultra/high settings with render scaling at 100 and Terrain LOD at 150. Objects LOD at 100.

I only have live weather ON with Bing and photo on as well. Multiplayer is off as well as live traffic is off.

Man, I’m always hopeful Asobo will fix these tiny stutters on every sim update, but I’m getting to the point where I think this will never get fixed.


You might want to have a look at this video from Pilot Pete. It does limit your fps to 30, but in my case greatly improved the smoothness of the animation (microstutters). In any case, it’s easily reversed if it doesn’t work for you.


This is a common question. Here is my reply to a similar post:

Performance Improvement Suggestion

Did you try to turn off VSync off?

Yes. Vsync is off

Well, non of these solved anything for me. It seems as if my hardware is already pushing out whatever is available. I think MSFS is still broken as far as this issue goes. Everything else is perfect for me.

If they can fix these tiny stutters, this sim would be 95% perfect.

Just don’t understand why they still have not fixed this after 4 sim updates already.

This is probably the communities biggest critic and Asobo does not seem to prioritize it.

Hopefully the sim will be silky smooth one day.


I use this guide to optimise my settings.

It also helps me to disable Hardware Virtualisation Technology and VT-d in my motherboard BIOS. It helps to stop the virtualisation function in the CPU and allows MSFS to take full utilisation of the CPU, removing the stutters as well as getting a stable frame rate at higher settings.

Disabling this changed my FPS from running in the 10-15 fps on Low settings and limited by mainthread, to a stable 30 fps on ULTRA at 2160p, that switches into limited by GPU, which is better.

I have virtualization off. But still no fix. Thanks for the tip though.

Well considering that Virtualisation is enabled as a factory setting default. It usually helps to check into BIOS and manually disable it.

Also I turn on Rolling cache and set it to 64 GB.

I run a 3440x1440 monitor with an i7 10700KF 32GB 2060super OC and I would suggest to avoid using FBW A32NX depending on where you fly. What ever method they are using to render the cockpit screens sucks. On the other hand I own the CRJ and that uses a different command (so I heard) to run the panels and its a lot smoother over FBW.
175 Terrain LOD,200 Obj LOD. Exactly similar results to your system but with my gpu limiting my fps mine tops out at 45fps once in the air,50 with a smaller plane.
On top of that the API is limiting the game.

If you’re GPU isn’t running at 90% to 100%, try lowering your LOD settings a small amount. But your FPS is already very good.

I have noticed that in general, FPS is lower on the ground compared to flying around. Also, the FBW A320 has a lower FPS than the A320NEO and other aircraft.

If you are seeing an FPS drop every 3 seconds, there might be an issue with peripherals such as VR or Bluetooth.

I have been in MS flight sims since 2006, (I am sure some of you even older than that) and ı always see guides, registry manipulations, txt codes, Nvidia menu mess-ups. But the truth is MS flight sims always make you suffer in terms of performance. So If you want to get into msfs series, you should accept the fact that your destiny is between 20-30 fps

1 Like

I think everyone is okay if they’re getting an average of 25-35 fps. We all agree that 60 fps stable on everything ultra is wishful thinking. It is expected to be that much of course.

But when you’re only getting barely 10 fps with major stuttering on a $5000 PC hardware components. You’d start to wonder and trying to figure out why that is the case and do any changes that we can do to bring it back to the acceptable 25-35 range.

I really don’t expect smooth 60 fps. I mean i do hit smooth 60 fps but only when about 12,000-15,000 feet in the air.

What annoys me are the tiny stutters which happen when on ground and you really notice them when taxiing and making sharp turns on taxi. This happens when I’m around 30-38 fps on ground. Once in the air, I’m smooth 40-60 fps.

I don’t mind 30 fps just as long as it is smooth with no tiny stutters which really kills the immersion for me.

I’ve tried everything and nothing works. Hell, I’ve dropped settings to the lowest possible which increases my fps a lot, but tiny stutters still remain.

When I fly other aircrafts like the cesna 172, it’s butter smooth at all times.

So I’m beginning to believe it’s an issue with the FBW A320. But if you ask the folks at the FBW discord, they say it’s an MSFS issue.

So I don’t know now.

That’s why I’m asking here to see if I missing something.

Try this to see.
I have noticed an improvement.

1 Like

Yeah, well apart from the disabling Hardware Virtualization technology in my BIOS, I also turn on Rolling Cache and set the size to 64 GB, that way, there’s enough space reserved in my SSD for the sim to grab the needed files and store them in the cache and just load the files locally instead of “streaming it” from the web which may also cause the stuttering if the internet connection isn’t smooth enough to do it live.

This is the video comparison between before I made the changes above (this is on Lowest Settings): https://youtu.be/6d9EeHNM1H8?t=25697

And after I made the changes (Optimised High-Ultra settings): https://youtu.be/bVwIgveOFEE?t=7994

You can also log MSFS2020 to always run in high priority automatically when you run it.

[HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Image File Execution Options \ FlightSimulator.exe \ PerfOptions]
“CpuPriorityClass” = dword: 00000003

or double click and the record will be created automatically.

If you run another aircraft and do not experience the same thing its an FBW system. Because I own the CRJ and that runs much smoother over the A32NX MOD that alone is enough evidence for me to believe the MOD is not well optimized.
Suggest checking this thread out A320 FBW vs CRJ FPS - #10 by HXArdito

What’s your nvidia settings? Try turning low latency to ultra

Yes CRJ is silky smooth so definitely FBW A320 isn’t optimized