What to do when UserCfg.opt is completely missing?

MSFS 2020 premium edition install on separate SSD (D:) drive, now refuses to load beyond the point where the screen goes full-screen and the white rotating circle at bottom right appears. Once the white rotating circle stops, the sim crashes back to desktop…

I have noticed that I do not have a UserCfg.opt file anywhere on any of my computer’s drives, let alone in any of the folders mentioned as containing the UserCfg.opt file!!

There is a 0kb FlightSimulator.CFG file in the Users/‘user’/AppData/Local/Packages/Microsoft.FlightSimulator_8wekyb3d8bbwe/LocalCache folder.
There is a 555Kb file (E39B5D33982B433AB222A90864F5DC94) in a /wgs folder of the SystemAppData sub folder of the Users/user/etc, etc. folder, that contains what appears to be some sim initial state settings with a whole pile of “nulls” scattered throughout.

This situation has been an almost instantaneous change from the sim running perfectly to not loading at all. The only change between was Nvidia drivers for a new 3060ti.

Any ideas regarding solution/s would be appreciated.
(BTW, I have attempted to restore a UserCfg.opt file from a Windows backup but have had zero success, so that option is now not an option.)

I would just find and delete all instances of usercfg.opt, load the sim, when it gets to the checking for updates screen choose the path were the sim is really installed, let it think a moment, then click ok and the sim should replace the missing usercfg.opt file.

But what your describing sounds like something is really messed on your system installation wise, you might just want to uninstall and resinstall from scratch.

AppData/Roaming/Microsoft Flight Simulator/UserCfg

If only there was, as I mentioned a usercfg.opt file to delete in the first instance…

And yes; there is something well and truly messed up.

I’ve tried to uninstall MSFS 2020 multiple times. When it reinstalls, it downloads 1.1Gig before installing just that 1.1Gig. Then when selecting play, because it won’t download any more than the 1.1Gig; it does exactly the same game start-up sequence that crashes back to desktop I originally described.

Even if I select to download the Premium version of the game I purchased back at release (so NOT the Steam version!!!) it still chooses to download the ‘standard’ 1.1Gig version of the game and just goes back down the same rabbit hole…

I’ve even reformatted the target drive so there is no trace of any previous MSFS 2020 installation on it - and even upgraded from Windows 10 to 11 to see if that makes a difference - but no.

It’ll probably be something really simple… but in the meantime; it’s pretty frustrating.

I did not purchase the Steam available version of the game.

I gather from what I’ve been able to research, that it appears the folder you pinpoint applies only to Steam versions of the game.

So when I do a clean re-install these are the steps that I follow (on steam version).

  1. delete the install from steam (should work in ms store as well)
  2. make sure that windows installer doesnt think its installed (remove apps tab windows)
  3. goto appdata folder, and click on local find the directory flightsimulator and delete that
    goto the roaming folder and delete the microsoftflightsimulator directory
  4. If you have a reg cleaner run that (optional)
  5. reboot

Now the machine should be clean of all remnants of the sim.

Now in MS store you have to play around with the menu selections to choose the right version ( I dont have ms store this is just what I have read in other threads) you might want to search these forums for installing from MS Store.

After doing all this it should work…

“It should work”… but it doesn’t.

Can’t get the machine much cleaner; short of a complete reformat. No remnants of MSFS 2020 on C: in folder/file or registry.

Game still doesn’t load after reinstall but crashes back to desktop.

there’s a limit to how much fiddling and farting around one is prepared to do…

1 Like