Whats wrong with the mouse inside the cockpit?

@Semor76

Or in other words: they simply not care and have 0 interest in fixing this bug before the next sim update in february.

Just to clarify - that’s not what was meant by the CM closing that thread. The #decupdateflight area of the forum is just for reporting/discussing new bugs that have appeared in the test builds, or things that are marked as fixed in each build’s notes.

As this particular bug first appeared in the main SU7 release (ie: before the beta began), and a patch for it has not yet been released, this remains the main thread for discussing/voting on the issue (to avoid splitting the discussion/votes). It doesn’t mean it won’t be addressed before the final hotfix build goes live, we’ll just have to wait and see what they manage to complete in that time.

Hope that clarifies things.

2 Likes

I’m am using the test build and this is definitely still an issue. Also, I didn’t see it on the list of bugs to fix so it looks like using basic controls in the cockpit of all planes will be painful for a while.

I have no idea why this was not a top priority as it was immediately discovered on patch day and not being able to interact with the cockpit is a show stopping issue. If everything is solely based on votes - this surely underscores failures in a blind democracy as most end users don’t know what’s really going on half the time.

I shouldn’t have to worry about shutting whole engines off on a takeoff when working a gyro or cowl flap.

5 Likes

this is killing the sim for me. how is it not a TOP priority bug.

FIX THIS ASAP

Even assigning another button to toggle cockpit freeloook STILL has the bug. so it’s tied to this action it seems

5 Likes

I’ll re-test this tomorrow in that case. Last time I checked, moving freelook toggle to right mouse instead of middle mouse meant zooming out was no longer there, and you could use the Next Pilot Position without a sim hang either.

1 Like

tried this and right click does seem to enable cockpiter interaction but it’s a 1-way move, can’t get back to free look with right click. odd

Nice, together with these two bugs:

https://forums.flightsimulator.com/t/bug-logged-freelook-with-mouse-causes-controls-to-freeze-after-su5/426349/360

https://forums.flightsimulator.com/t/mouse-cursor-randomly-doesnt-reappear-when-moving-around-translation-in-the-cockpit-after-last-mouse-going-to-top-left-corner-fix/429866/133

They have now almost managed to completely ruin the primary way to interact with the sim, whilst also not really caring about fixing any of it :joy:

Almost impressive.

7 Likes

Saying they don’t care is a bit of a stretch don’t you think?

I used the sim for roughly 30 hours over the last week, and many others are the same, which may be the reason why it has gained as much visibility as you think it should.

I take part in as many group flights as I am able, and we regularly see a lot of people doing the same.

If it were as bad as you suggest they wouldn’t be happening at all.

i agree. all of these small, quickly-fixable bugs end up causes massive headaches for users.

at least we know what is going on. many people encounter these debilitating bugs and think it’s THEIR fault somehow, or that their computer/hardware is breaking on them. it’s honestly super messed up when you think about it.

and pretty infuriating that they just don’t quickly release a hotfix immediately as these bugs affects everybody and can cause the game to be unflyable if you don’t know the little tricks to get things working again

6 Likes

Glad I’m not the only one to think it’s completely insane! :joy:

And yeah, without exaggerating, I haven’t seen these types of core issues go for this long without any type of fix or acknowledgement. We’re talking over half a year now. Don’t know what to say or do about it any longer.

3 Likes

Any fix for this yet ?

short answer… NO :frowning:

1 Like

This is ridiculous, how can things like this be overlooked?

4 Likes

Sad to say this is still happening after yesterday’s patch.

Please look into this!

1 Like

Asobo pass to fix this, since SU5 and no updates from devs. So sad.

1 Like

i don’t think this bug will be fixed yet… i think we all have to get used to the new handling. :frowning:

thing is it doesnt reset view in INSTRUMENT mode so you can operate camera just the way before this bug and still be able to operate flight controls. if only we could create custom views…i hate Asobo

1 Like

You sure its not your mouse that is the issue!

Delete your mouse driver restart computer it will reinstall the mouse driver and check if it fixed it.
Had the same issue and that fixed it for me.

mouse DRIVER? you sure you are not from 1995 or something?

What a strange comment.

I don’t know if it will fix the problem, but mouse drivers certainly still exist. I have them for my Logitech mouse etc. in the year 2022 :slightly_smiling_face:

1 Like

Why do you have multiple drivers. I have 1 entry

1Mouse